HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

XML parsoing on OpenVMS 7.3

 
Wim Van den Wyngaert
Honored Contributor

XML parsoing on OpenVMS 7.3

I got the question to have the XML tools on OpenVMS 7.3. Info http://h71000.www7.hp.com/openvms/products/ips/xml/

It is stated in the XML C requirements that 7.3-2 is needed. Did anyone try it on 7.3 or lower ? Problems ?

Anyone using it on 7.3-2 or higher ? Problems ?

Wim
Wim
8 REPLIES
Wim Van den Wyngaert
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

I would also like to avoid ODS-5 disks. Possible ?

Wim
Wim
Ian Miller.
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

You can but try it I suppose.

You may also find this of interest
http://h71000.www7.hp.com/freeware/freeware80/libxml2-2_6_20/
____________________
Purely Personal Opinion
Wim Van den Wyngaert
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

Ian,

What is the added value iof libxml ?

Wim (JuniorXml)
Wim
labadie_1
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

>>>I would also like to avoid ODS-5 disks. Possible ?

yes, if memory serves me, LD is available, but hidden with Vms 7.3. You just have to start it ( something like @sys$startup:ld$startup) and then you create a disk (LD create...), which can be ODS-5, using some free space on a ODS-2 disk.

Not tested though
Arch_Muthiah
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

Wim,

We had XML C Version 2.0 on OpenVMS Alpha Version 7.2-2.

The C compiler version is cpq C V6.5 or above for OpenVMS Alpha.

It was working fine with Ovms V7.2-2, infact XML C V2.0 requirement is openVMS 7.2-2 and above only.


Archunan
Regards
Archie
Arch_Muthiah
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

Wim,

If you want to have xml c V 2.0-1, then we need OpenVMS 7.3-2 and above. This is what xml c V 2.0-1 release notes says. I don't have now.


Archunan

Regards
Archie
Jean-François Piéronne
Trusted Contributor

Re: XML parsoing on OpenVMS 7.3

Wim,

you may find PCSI kit of LIBXML2 V2.6.20
and Libxslt/Libexslt V1.1.12 on

http://www.pi-net.dyndns.org/anonymous/kits/

JF
Wim Van den Wyngaert
Honored Contributor

Re: XML parsoing on OpenVMS 7.3

Installed the C++ stuff without any problem. Tried running it and got a shareable image mismatch. Rebuild done without major problems (increase pgflq). Took a few hours on a 4100.

Installed the LIBXML2 stuff. Also a mismatch. Rebuild didn't work. Removed a 'goto foo' in the build procedure. Stopped because glob.h not known on this C version. Removed the runtest from the compile list and restarted the build. Went fine. Took about 1 hour.

Did a run of testapi. It said something about a leak and "null handler" but that could be normal.

This morning got an alarm. Testapi created 19.000 versions of test.out.

C++ 6.5, C 6.5 on 7.3 not fully patched.

I'll do an update when I get feedback from the user.

Wim
Wim