Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

apache error:"child pid ***** exit signal bus error"

yanxw
Occasional Visitor

apache error:"child pid ***** exit signal bus error"

Hi,I use CSWS 2.1 on alpha VMS 8.2, all patches intalled.
But my webserver is not stable,sometimes it submit sucess,sometimes it failed,I look for the error_log,found this:
-------------------------------
[Wed Feb 13 15:12:38 2008] [notice] child pid 568624367 exit signal unknown sign
al (number) (114)
-------------------------------
Any ideas?
5 REPLIES
Willem Grooters
Honored Contributor

Re: apache error:"child pid ***** exit signal bus error"

When does this happen:
* when servicing plain HTML
* when servicing JSP, Java (Tomcat)
* when servicing PHP or Perl

What does the server log tell you?

Willem
Willem Grooters
OpenVMS Developer & System Manager
yanxw
Occasional Visitor

Re: apache error:"child pid ***** exit signal bus error"

Hi,Willem
When servicing PHP,it happened!
server log? I don't know what do you mean,I had listed the server
error_log! What do you need any more?
Thanks for your reply!
Willem Grooters
Honored Contributor

Re: apache error:"child pid ***** exit signal bus error"

It might well be that the problem is not within Apache itself, but in the PHP module.
There are some issues with this software. I run into issues within the PHP module once in a while, that I cannot trace down:

%DEBUGBOOT-W-CHN, assign channel system service request failed
or
%SYSTEM-F-HPARITH, high performance arithmetic trap ...

Since the big part of it is a shared aimage (PHPSHR) built /NOTRACEBACK, so locating the error is virtually impossible. (The same applies to debugging PHP code) but I could track them down deep into the PHPSHR image, calling DECC_runtime routines...

I'm not using Apache so it might be that using Apache, you could get other messages.
One thing that could be the case: if the error code (114) is actually a VMS error code, it means:

%SYSTEM-E-DEVNOTMBX, device is not a mailbox

that may be related to the "debugboot' message I get (I could'nt track that message either).

I'm sorry I cannot help you further than to suggest you to log a call with HP (if you have a support contract).
Willem Grooters
OpenVMS Developer & System Manager
Willem Grooters
Honored Contributor

Re: apache error:"child pid ***** exit signal bus error"

This might be interesting:

http://groups.google.com.au/group/comp.os.vms/msg/a48e941bc5e2871c
Willem Grooters
OpenVMS Developer & System Manager
yanxw
Occasional Visitor

Re: apache error:"child pid ***** exit signal bus error"

Willem Grooters ,thanks for what you do,though I don't solve the problem!
I'll try another way~