Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

cannot upgrade to 7.3-2...

SOLVED
Go to solution
Willem Grooters
Honored Contributor

cannot upgrade to 7.3-2...

Two weeks ago, I deided to upgrade from 7.3-1 to 7.3-2, but just before the execution phase started, I got a message to extract "this PSCI" and from that set, a commmandfile, and after that, run that ommandprocedure. Given the name, it had to do with Kerberos.
I didn't have a lot of time so I restored my system. read the installation guide (Ok, I knew I should have done that before...), and took a look on kerberos. To my surprise, it wasn't mentioned in PROD SHOW HIST...

This weekend, I first removed kerberos, and restarted the upgrade. To my BIG surprise, the procedure signalled kerberos 1.0 found so it would be upgraded!
So fisrt of all, I removed kerberois again (said "in transition"), extrated the file I expeeed to be the right wone (version 2.0) and did what the message told me: first REMOVE and then install the overlay.
Next, I ran the installation again. But again, I got this message and, directly, just after 0% is shown in execution, the execution phase failed again due to an error.
It does NOT show what error, nor where. Just that smething went wrong...

A clean install however proved NO problem at all, but a lot of things needed to be redone. Most important part has, took me a day...

I have no output (at the moment), I could retry if needed - when time permits. But I just wonder why this happened.
Willem Grooters
OpenVMS Developer & System Manager
6 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: cannot upgrade to 7.3-2...

Hello Willem,

as you would have guessed, generally speaking upgrading from 7.3-1 to 7.3-2 works fine. I just did it on my AlphaServer 800 under the desk very recently. The transition message
should not be a problem (I do have both transition reg product and transition remove in my PCSI history). Did you maybe still have logicals assigned or some such or have Kerberos images installed that could not be removed.

Greetings, Martin
Willem Grooters
Honored Contributor

Re: cannot upgrade to 7.3-2...

Thanks for the idea Martin - but I don't think logicals could be the point. After booting from CD it's quite unlikely that Kerberos logicals are set up the way it would if booted from disk, nor imgaes would have been installed.
I also used option 6 - Remove installed products - to get rid of Kerberos. A bnext view didn't reveal any Kerberos - as expected. Yet, upgrade immediately after that DID tell me Kerberos 1.0 existed on the system and would be upgraded!
What worries me more is that I don't know what caused the installation to fail.

One other thing I forgot to mention:
The first time started, the upgrade signalled two programs: SYS$LDR:SYS$DUDRIVER_MON.EXE and SYS$LDR:SYS$TUDRIVER_MON.EXE that would cause problems in certain circumstances, then it tells these programs should be moved to another place or renamed. So I did. No problem to boot VMS without them. But could it be that the procedure failed because these programs were not found? In that case, the suggestion should tell me something different!
Nothing in the installation guide either. It ought to have been mentioned there as well.

Willem
Willem Grooters
OpenVMS Developer & System Manager
Haim Godovnik
Occasional Visitor
Solution

Re: cannot upgrade to 7.3-2...


Please install VMS731_PCSI V0200 kit before upgrade to VMS V7.3-2.

From VMS731_PCSI release notes :



8.1.7 Upgrade of OpenVMS V7.3-2 from V7.3-1 fails if
DCE_030_SSRT3608-0100 kit is installed at the time of
the upgrade

8.1.7.1 Problem Description:

The upgrade of OpenVMS V7.3-2 from V7.3-1 will fail if
the remedial kit DCE_030_SSRT3608-0100 is installed at
the time of the upgrade.

Images Affected:

- [SYSEXE]PCSI$MAIN.EXE

- [SYSLIB]PCSI$SHR.EXE




8.1.7.5 Problem Analysis:

The error condition reported implies that the wrong
version of the KERBEROS product is installed which
prevents a newer version of KERBEROS from being installed
as part of the OpenVMS upgrade. The real problem,
however, is a logic error in the PCSI utility triggered

by a very specific set of conditions that are present in
this upgrade scenario.
Martin P.J. Zinser
Honored Contributor

Re: cannot upgrade to 7.3-2...

Hello Willem,

Haim gave you the answer to the original problem. As for the _mon images. These can be safely removed. If you look you will notice that for each xxx_mon.exe there is an xxx.exe, which is the image normally used. The mon version is/was instrumented to provide additonal information in error situations.

Greetings, Martin
Willem Grooters
Honored Contributor

Re: cannot upgrade to 7.3-2...

Haim,
Thanks...

I was thinking of installing a systemn upgrade so why bother on patches on the version to be upgraded...
Now I know.

I wonder - has HP not tested this combinations? Seems not ....(or has this DCE-patch been delivered AFTER this testing? it _should_ have been redone IMHP).

Though I installed 7.3-2 from the ground up, I'll try your suggestion - having the original system back ahs it's advantages ;-)

Willem
Willem Grooters
OpenVMS Developer & System Manager
Willem Grooters
Honored Contributor

Re: cannot upgrade to 7.3-2...

FYI
This weekend I restored 7.3-1 system from backup, installed the PCSI-patch and peformed the upgrade - without any problem.
Willem Grooters
OpenVMS Developer & System Manager