HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

cifs 1.1 smbclient does not ask for password

 
Jeff Byrkit
Occasional Advisor

cifs 1.1 smbclient does not ask for password

I installed CIFS 1.1 on vms 8.3 with vms83a_acrtl v4 and vms83a_update v6. When I try to use smbclient, it does not ask for the password:

BETA> smbclient --list pdc --user administrator
session setup failed: NT_STATUS_LOGON_FAILURE

however, on another 8.3 vms box I installed T1.1 and it does ask for the password:

$ smbclient --list pdc --user administrator
Password:
Domain=[PAO2K] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Wi
ndows Server 2003 5.2]

Sharename Type Comment
--------- ---- -------
ESRI Conference 2008 Disk
C$ Disk Default share
handheld Disk
profiles Disk
vmsdocs Disk
PCPAO Disk
backup_dhcp Disk
PLTS Reviewer Projects Disk
F$ Disk Default share
IPC$ IPC Remote IPC
software Disk
ADMIN$ Disk Remote Admin
here is smb.conf (on both boxes):

[global]
workgroup = PAO2K
server string = Samba %v running on %h (OpenVMS)
security = share
log file = /samba$root/var/log_%h.%m
load printers = No
; domain logons = Yes
; domain master = Yes
create mask = 0755
[homes]
comment = Home Directories
read only = No
create mask = 0750
browseable = No

am I crazy?