Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

curl on vms 7.3-2

robert70
Valued Contributor

curl on vms 7.3-2

Hi
trying to connect to server with CURL
CURL version 7.16.2
VMS 7.3-2

getting the following error

* About to connect() to proxy nn.nn.nn.nn port 8080 (#0)
* Trying nn.nn.nn.nn... connected
* Connected to nn.nn.nn.nn (nn.nn.nn.nn) port 8080 (#0)
* Establish HTTP proxy tunnel to www.test.com:443
* Server auth using Basic with user 'test'
> CONNECT www.test.com:443 HTTP/1.0
> Host: www.test.com:443
> User-Agent: curl/7.16.2 (ALPHA-HP-VMS) libcurl/7.16.2 OpenSSL/0.9.7e
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* libcurl is now using a weak random seed!
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify faile
d
* Closing connection #0
%CURL-E-SSL_CACERT, SSL CACERT, problem with the CA cert (path?)


Any help ?
10 REPLIES
Hoff
Honored Contributor

Re: curl on vms 7.3-2

Verify the certificate on the target server, update the certificate and correct the error, or disable certificate verification with your curl command.

Running a Google search for you with the search target of curl with with the cited error message text finds this posting:

http://curl.haxx.se/mail/archive-2003-03/0033.html

Which points to this write-up:

http://curl.haxx.se/docs/sslcerts.html

Does that help?
robert70
Valued Contributor

Re: curl on vms 7.3-2

a slightly different problem now
im using the -k flag to bypass the certification

im now seeing this:-


< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* libcurl is now using a weak random seed!
* SSLv2, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using DHE-RSA-AES256-SHA
* Server certificate:
* subject: C=GB, ST=Herts, L=St Albans, O=test Group Ltd, OU=sfa30052www001, O
U=Terms of use at www.verisign.co.uk/rpa (c)05, OU=Authenticated by VeriSign, OU=Member
, VeriSign Trust Network, CN=www.test.com
* start date: 2008-10-23 00:00:00 GMT
* expire date: 2011-11-30 23:59:59 GMT
* common name: www.test.com (matched)
* issuer: O=VeriSign Trust Network, OU=VeriSign, Inc., OU=VeriSign International
Server CA - Class 3, OU=www.verisign.com/CPS Incorp.by Ref. LIABILITY LTD.(c)97 VeriSi
gn
* SSL certificate verify result: unable to get local issuer certificate (20), continuing anyway.
* Server auth using Basic with user 'test'
> GET /export.jsp HTTP/1.1
> Authorization: Basic c2FuZGlzb3I6cGFzc3dvcmQy
> User-Agent: curl/7.19.5 (ALPHA-HP-VMS) libcurl/7.19.5 OpenSSL/0.9.7e
> Host: www.test.com
> Accept: */*
>
< HTTP/1.1 200 OK
< Date: Fri, 30 Oct 2009 16:21:20 GMT
< Server: Apache/2.2.3 (Red Hat)
< Set-Cookie: JSESSIONID=933065687AC6DE8EC447F884C601007B; Path=/; Secure
< Content-Length: 18
< Connection: close
< Content-Type: text/plain; charset=UTF-8
<
Error logging in
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):


any ideas?
Hoff
Honored Contributor

Re: curl on vms 7.3-2

Please post the full curl command used here.

Kindly confirm your login credentials are valid for the target host, if you're using those to access this server.

Do confirm that curl works from another local client host into this same target; that curl itself isn't intentionally blocked at the target web server.

And FWIW, here is the curl support mailing list, if you're interested in pursuing this with folks that know curl rather well:

http://curl.haxx.se/mail/
Bill Pedersen
Regular Advisor

Re: curl on vms 7.3-2

I sent a note off to John Malmberg who is a member of the OpenVMS Community but who is also heavily involved with cURL suggesting he check in here and see if he can help.

Bill.
Bill Pedersen
CCSS - Computer Consulting System Services, LLC
Telephone: 864-490-8863
Facsimile: 206-984-3068
John Malmberg_1
Occasional Visitor

Re: curl on vms 7.3-2

A similar question was posed on comp.os.vms on October 12th.

The parameters to curl may be case sensitive.

At a minimum you need to quote the exact case parameters.

robert70
Valued Contributor

Re: curl on vms 7.3-2

heres the command ive been using


$ curl -v -k -x proxy.uk:8080 -U username:password
-f user=test -f password=password -f date=20091029 -f format=xml
-f report=COMPOSITES_BY_CONVENTION -f version=5
-f type=test https://www.test.com/export.jsp
Hoff
Honored Contributor

Re: curl on vms 7.3-2

You can use

$ SET PROCESS /PARSE=EXTENDED

in the context of this process,

or you can double-quote the "-U" option to force DCL to use it as upcase. (OpenVMS automatically down-cases all switches when using the default traditional parsing.)

And as a personal preference when shell-scripting stuff, I'd probably also try to use the newer syntax switches (eg: switching from -U to --proxy-user, for instance) to clarify the operations.

robert70
Valued Contributor

Re: curl on vms 7.3-2

thanks
the case sensitive nature of the curl did seem to be the problem as I am now able to get the file
however another problem now
when doing thia on a PC and placing the output in a file called Z.ZIP we can then unzip and use the XML file no problem. however when trying to UNZIP the file on VMS get the following error:-

$unzip y

Error: zipfile is in variable-length record format. Please
run "bilf l DAVE$DKB1:[CURL]Y.ZIP;22" to convert the zipfile to stream-LF
record format. (BILF is available at various VMS archives.)


Tried various converts i have seen on other forums and dosent seem to work -
also trying to load bilf i get the following problem when I build the c program (vaxcrtl.exe not on the sys$share directory?:-

$ @build
$ cxx tom.c
$ link tom,sys$input:/opt sys$share:vaxcrtl.exe/shareable
%DCL-W-MAXPARM, too many parameters - reenter command with fewer parameters
\SYS$SHARE\
$ ! change the following symbol to "$diskname:[directory]bilf.exe" as approp.
$ bilf == "$d:[user.tom.src.test]tom.exe"
$ set noverify
$

any other pointers would be great
Steven Schweda
Honored Contributor

Re: curl on vms 7.3-2

> Tried various converts i have seen [...]

Not a useful description of what you tried,

> [...] dosent seem to work -

Not a useful description of what happened
when you did whatever you did.

> also trying to load bilf [...]

You may be digging yourself a deeper hole
with this fossil. Better to get the file
attributes right to begin with.

> [...] DAVE$DKB1:[CURL]Y.ZIP;22 [...]

If you really have multiple versions of this
thing, I'd start by deleting them all. It's
possible that when you fetch a new one, it
inherits the (defective) attributes of an
existing version. I use wget more than cURL,
but I'd expect either one to create stream_lf
or fixed-512 files unless something steers it
wrong.


> $ @build
> $ cxx tom.c
> [...]

I may be sorry I asked, but what is all this
stuff? "cxx"? Yikes.
robert70
Valued Contributor

Re: curl on vms 7.3-2

close this - opening new thread re the unzip problem