cancel
Showing results for 
Search instead for 
Did you mean: 

de500

bernie_9
Occasional Visitor

de500

I have an AS2100 withtwo network cards inside it, 1 x 10base2t and the other 100baset. I can ping internally but not externally, is there some setting I need to be aware of? I'm using the 100baseT card ewb0 for the pinging. I've checked at the >>> and the option is set to fast. Is there a quick way to check the card out?
9 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: de500

Hello Bernie,

to check the settings:

mcr lancp
LANCP> show dev ewa0/char

Device Characteristics EWA0:
Value Characteristic
----- --------------
1500 Device buffer size
Normal Controller mode
External Internal loopback mode
00-00-F8-06-88-5A Hardware LAN address
Multicast address list
CSMA/CD Communication medium
FF-FF-FF-FF-FF-FF Current LAN address
128 Minimum receive buffers
256 Maximum receive buffers
Yes Full duplex enable
Yes Full duplex operational
TwistedPair Line media type
100 Line speed (mbps)
Disabled/No Failset Logical LAN state
0 Failover priority


Replace ewa0 with ewb0 for your config.

Also show dev/full should verify the card in use (again replace ewb0 for your config)

$ show dev ewa0/full

Device EWA0:, device type DE500, is online, network device, device is a template
only.

Error count 0 Operations completed 0
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G,W
Reference count 0 Default buffer size 512


How does tcpip show inter look like? Which address do you try to ping? The best choice is the next router to you.

Greetings, Martin
bernie_9
Occasional Visitor

Re: de500

I did a show dev full under VMS and it looks like you script. I'm try to ping an address on the same network, I'm xxxxx.6 and the other address is .7. The activity light is flashing constantly on the router and the interface card. The environment at the >>> is set to fast, can't do fast_fd. Would it be worth just removing the ewa0 card? I'm not using an ethernet conection? When VMS comes up it states that the ethernet connection has been selected, is this a red herring or can this be disabled somewhere?

Any help?

Thanks Bernie
Bojan Nemec
Honored Contributor

Re: de500

Hi,

How about TCP/IP settings, is the interface properly configured?

You can verify the settings with:

$ TCPIP ! or UCX on older VMS versions
TCPIP> SHOW INTERFACE/FULL

This shows you the settings and the counters for each interface (network card + loop device)

Bojan
Anton van Ruitenbeek
Trusted Contributor

Re: de500

Bernie,

How about the speed ?
In >>> show ew* and/or show ei* depending an the type of cards.
Linespeed should be correct for the switch or hub which you are using.
Watch also about the duplex/full duplex setting. If you are using autonogotiating: Switch this off. Most of the switches won't work correctly. Fur sure: 3com, Cisco.
Set the ports if you can to 100 Mb/Full Duplex and most of the times this will do the trick.
Hubs are halfduplex.

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
bernie_10
Occasional Visitor

Re: de500

Checked the ewb0: using LANCP, all looks OK except the buffers are set to 32.

At $show dev ewb0/full alllooks OK.

Not sure how too disable autonogotiating.

I'm on VMS Ver 6.2-1H3, can't seem to get TCPIP to work.

The card is set with
IP 10.1.100.6
Network 255.255.255.0
Brdcst 10.1.100.255

The activity light is constantly flashing, not sure why this is happening when nothing is going on?

Any other ideas?

Regards Bernie
Bojan Nemec
Honored Contributor

Re: de500

Hi,

If you are on VMS 6.2-1H3 use

$ UCX

instead of

$ TCPIP

Or perhaps you are using another third party TCP/IP stack?


At the UCX prompt type:

UCX> SHOW INTERFACE/FULL


This will display you the interface settings and also the counters on each card (Receive and send packets etc...)


Also as mentioned by Anton you must properly set the linespeed and the half - full/duplex settings on the switch. Disable autonegotiating.

And I remember that there is almost one ethernet card that you can 'overspeed' in >>>.
With overspeed I intend that you can set Fast Full duplex on a 10baseT card.
Now I cant remember which adapter was, the only thing I remember is that it was an AS 1000 alpha.

Bojan.
Dan Montes
Occasional Visitor

Re: de500

Don't forget that you need a default route for each interface. A route defines a routing path in either the permanent or volatile routes database. See VMS TCPIP help for examples.
Dima Bessonov
Frequent Advisor

Re: de500

Hi Bernie,

I too had a problem with DE500-BA on AS2100 in the past...

There are several variants of DE500. Depending on the combination of your OpenVMS version and the DE500 variation, it may be working or not. There are certain HP requirements about that. There are ECO kits that enable support of DE500 for specific versions of OpenVMS. Try to look up the necessary patch at http://www2.itrc.hp.com/service/patch/mainPage.do . Its name should start with "ALPLAN" or "ALPBOOT".

There was also quite a bit of answers about DE500 at OVMS Ask The Wizard. Try to do a search for "DE500" at http://h71000.www7.hp.com/wizard/ .

Cheers,
Dima
Martin P.J. Zinser
Honored Contributor

Re: de500

Hi,

there is a discussion of the various DE500 variants in the FAQ at

http://h71000.www7.hp.com/wizard/faq/vmsfaq_019.html#supp9

Having said that, if you get it to work, the DE500 is really great for a 100Mbit card.

Greetings, Martin