HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

decnet loop issue

 
SOLVED
Go to solution
skynet1980
Occasional Advisor

decnet loop issue

I have a question about decnet loop issue. When i do loop testing from my vax server to another vax server:
mc ncp
ncp>loop node ***
%NCP-W-MIRCTF, Mirror connect failed , Access control rejected
Messages not looped = 1
so i telnet to that server and do the loop testing to my vax server, no problem. but loop itself the same problem:%NCP-W-MIRCTF, Mirror connect failed , Access control rejected
Messages not looped = 1
What is the problem ? Is it caused by mirro$server settings?
5 REPLIES
Volker Halle
Honored Contributor
Solution

Re: decnet loop issue

skynet1980,

welcome to the OpenVMS ITRC forum.

The NCP LOOP application will connect to the MIRROR object or MIRROR session control application on the destination node. If it can't connect to that application due to missing username/password information, you'll see this error message.

Check the following on the destination node:

MC NCP SHOW OBJ MIRROR (DECnet Phase IV) or
MC NCL SHOW SESS CONT APPLIC MIRROR ALL (DECnet-Plus)

DECnet Phase IV needs a valid username/password, which matches the entry in SYSUAF.
DECnet-Plus just needs a valid username.

Volker.
skynet1980
Occasional Advisor

Re: decnet loop issue

hi volker
Yes , my decnet version is IV. and i also used: loop node xxx password xxx user xxx. and it was ok. But actually, there 2 vax servers that buildup a cluster. I used loop node xxx to both of the 2 servers. One is ok , but the other is not ok. They have the same decnet version, and the same uaf. So i am not clear about it.
Ian Miller.
Honored Contributor

Re: decnet loop issue

do the two VAXes use the same system disk and do they both have the same DECnet objects defined

Are there any additional messages in operator.log or audit log about the failed connect?
____________________
Purely Personal Opinion
skynet1980
Occasional Advisor

Re: decnet loop issue

hi miller,
yes, they have the same system disk and the same sysuaf. the obj define seems the same.when i use loop node xxx on that vax server to loop itself , it displays the same error message:%NCP-W-MIRCTF, Mirror connect failed , Access control rejected
Messages not looped = 1
but loop other node on that server, it is ok.(include looping its cluster member)
Volker Halle
Honored Contributor

Re: decnet loop issue

Hi,

I believe this is the 'classic' DECnet object password problem in a cluster with a shared SYSUAF file.

Please check, whether MC NCP SHOW OBJ MIRROR (with privileges turned on), shows the SAME password on both nodes !

DECnet Phase IV generates 'unique' passwords for some of it's DECnet objects during @NETCONFIG. It does so for each node you configure on your shared system disk, but the password of the second node you're configuring overwrites the password for the first node in SYSUAF.

Once you've found that the passwords are different, use the password from the 'working' (remote) node and use MC NCP DEF OBJ MIRROR PASS xxx on the failing (remote) node and then reload the object mit MC NCP SET OBJ MIRROR ALL

Volker.