Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

does SYSMAN from 7.3-2 to 7.2-2 system work?

 
Ron Maillet
Occasional Contributor

does SYSMAN from 7.3-2 to 7.2-2 system work?

All systems have separate system disks.

MCR SYSMAN SET ENV/CLUS does not work on the
7.3-2 system, does work from the (4) 7.2-2 systems. MCR SYSMAN SET ENV/CLUS/USER=xxx *does* work from the 7.3-2 system.

The failure message is SMI-E-ABORT error.

The SYSUAF, NETPROXY logicals look good.
I've restarted SMISERVER several times on all nodes. NCP OBJ SMISERVER (phase IV) seems to have no effect.

HP Support suggested we ensure all the MANAGE patches are up-to-date. They are.

Help, I'm just looking for other means to troubleshoot the thing, if I need to get into ANALYZE/SYSTEM, etc.

thanks for any pointers...

-Ron-
11 REPLIES
Andy Bustamante
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?


Do you have a common sysuaf.dat/rightslist with the appropriate logicals defined in your cluster?

Andy
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Ron Maillet
Occasional Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Andy,

Yup, the logicals SYSUAF, NETPROXY and RIGHTSLIST all point to the same common disk and directory COMMON0:[SYSEXE]

thanks...

-Ron-
Volker Halle
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Ron,

if you use the same username you are logged into on the V7.3-2 system, does it works as well with SET ENV/CLUS/USER= ?

Does it fails on every kind of command ? Even a simple SYSMAN> SHOW PROFILE ?

The SMISERVER DECnet object is only used, if you use SYSMAN command to a remote node outside your cluster. Having multiple SYSUAFs in a cluster would not be a problem for SMISERVER. Even having different SYSUAFs is not a problem, if the user is not in one of the SYSUAFs, you get an appropriate error from that node, if you try to execute SYSMAN commands there.

Volker.
Wim Van den Wyngaert
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Did you start SMI server with the SYSTEM account (@sys$system:startup SMISERVER) ?
Is SYSTEM having all privs ?

Did you check quotas of SMI server (should not be the problem because /user works but you never know)?

Did you check accounting file for info of the process (may show the real message) ?

Did you check the operator log file ?

Did you check for audit alarms ?

Are all cluster nodes 7.3-2 or is this a mixed cluster ? Is sysuaf shared ?

Wim
Wim
Mike Reznak
Trusted Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Hi,
just to make sure, because you've written, that the latest patches were instaled.
You have to have VMS722_MANAGE-V0100 which had been superseded by VMS722_UPDATE-V0100. This problem had been described there.

Mike
...and I think to myself, what a wonderful world ;o)
Ron Maillet
Occasional Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Thanks everyone!

First of all, I have a red face. The 7.2 nodes are 7.2-1 not 7.2-2 as I stated originally. I went from one environment to another to compare settings (they are both broken), but my immediacy is on the 7.2-1/7.3-2 environment. I apologize for this screw-up.

All seperate systems disk, with common disk for UAF, RIGHTSLIST, queues, etc.:

On the (4) 7.2-1 systems:
MCR SYSMAN SET ENV/CLUS works to all 5

On the (1) 7.3-2 system:
MCR SYSMAN SET ENV/CLUS/USER=FIELD
works to all 5 nodes

On the (1) 7.3-2 system:
MCR SYSMAN SET ENV/CLUS fails:

$ mc sysman set env/clus
%SYSMAN-I-ENV, current command environment:
Clusterwide on local cluster
Username FIELD will be used on nonlocal nodes

SYSMAN> do sho time
%SYSMAN-I-OUTPUT, command execution on node VM721A
%SYSMAN-I-NODERR, error returned from node VM721A
-SMI-E-ABORT, SMI Server has aborted
%SYSMAN-I-OUTPUT, command execution on node VM721B
%SYSMAN-I-NODERR, error returned from node VM721B
-SMI-E-ABORT, SMI Server has aborted
%SYSMAN-I-OUTPUT, command execution on node VM721C
%SYSMAN-I-NODERR, error returned from node VM721C
-SMI-E-ABORT, SMI Server has aborted
%SYSMAN-I-OUTPUT, command execution on node VM721D
%SYSMAN-I-NODERR, error returned from node VM721D
-SMI-E-ABORT, SMI Server has aborted
%SYSMAN-I-OUTPUT, command execution on node VM732A
27-OCT-2005 11:24:57
SYSMAN>

[Volker]

if you use the same username you are logged into on the V7.3-2 system, does it works as well with SET ENV/CLUS/USER= ?

Yes

Does it fails on every kind of command ?

Yes, even SHOW PROFILE

Even a simple SYSMAN> SHOW PROFILE ?

thanks for the info on NCP objects

[Wim]

Did you start SMI server with the SYSTEM account (@sys$system:startup SMISERVER) ?

yes I did, I did a STOP/ID and restart

Is SYSTEM having all privs ?

yes

Did you check quotas of SMI server (should not be the problem because /user works but you never know)?

did not check quotas yet

Did you check accounting file for info of the process (may show the real message) ?

no entry in the accounting file

Did you check the operator log file ?

no entry in operator.log

Did you check for audit alarms ?

not yet

Are all cluster nodes 7.3-2 or is this a mixed cluster ? Is sysuaf shared ?

one 7.3-2 can't sysman to four 7.2-1 nodes
all (4) 7.2-1 can sysman to the 7.3-2

yes sysuaf is shared

[Mike]

just to make sure, because you've written, that the latest patches were instaled.
You have to have VMS722_MANAGE-V0100 which had been superseded by VMS722_UPDATE-V0100. This problem had been described there.

good point: actually because I inadvertantly lied about the version, I looked up the patches that the admin installed (both appear to be the latest):
DEC AXPVMS VMS721_MANAGE V2.0
DEC AXPVMS VMS721_UPDATE V3.0
Robert_Boyd
Respected Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

You say this is in a V7.3-2 / V7.2-1 cluster?

This is a "non-supported" configuration -- so it's no surprise that it is having issues. The earliest Alpha version supported as interroperable with V7.3-2 is V7.2-2.

I can say from experience that V7.2-2 works pretty well with V7.3-2. I never took the chance to find out about 7.2-1 with 7.3-2.

Robert
Master you were right about 1 thing -- the negotiations were SHORT!
Ian Miller.
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Upgrading V7.2-1 to V7.2-2 is like installing a big patch kit and worth doing.

There are compatabilty issues between versions which are sometimes fixed with the MANAGE patches but it may be that for V7.2-1 they did not.
____________________
Purely Personal Opinion
Ron Maillet
Occasional Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Thanks all,

It looks as though the bug fix is included in the VMS722_MANAGE-V0100 patch. The issue is that after a SYSMAN SET ENV/CLUS issuance, the username for the SMISERVER process does not revert back to the (original) SYSTEM account. It is clearly described in the "bug fixes" section.

Unless anyone has a fix (hint hint) for 7.2-1, I would say that the customer is out of luck for now, since upgrading the four 7.2-1 nodes to 7.2-2 can't happen for several months.

thanks so much..

-Ron-

(this is my first foray in this forum, so I'm new to the "protocol")
Jan van den Ende
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Ron,

Please read:

http://forums1.itrc.hp.com/service/forums/helptips.do?#33

Mind, I do NOT say you necessarily need to give lots of points. It is fully up to _YOU_ to decide how many. If you consider an answer is not deserving any points, you can also assign 0 ( = zero ) points, and then that answer will no longer be counted as unassigned.
Consider, that every poster took at least the trouble of posting for you!

To easily find your streams with unassigned points, click your own name somewhere.
This will bring up your profile.
Near the bottom of that page, under the caption â My Question(s)â you will find â questions or topics with unassigned points â Clicking that will give all, and only, your questions that still have unassigned postings.

Thanks on behalf of your Forum colleagues.

Proost.

Have one on me.

jpe
Don't rust yours pelled jacker to fine doll missed aches.
Jan van den Ende
Honored Contributor

Re: does SYSMAN from 7.3-2 to 7.2-2 system work?

Oh my,

I _am_ being rude!

Sorry Ron,

of course I should have started with a wholehearted:

"Welcome to the VMS forum".

Proost.

Have one on me.

jpe
Don't rust yours pelled jacker to fine doll missed aches.