Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

locked tape device

 
FrenkyBee
Occasional Visitor

locked tape device

Via deviceshare we have connected a tape drive. The user that connected the drive is logout without dismounting the drive, and now we have a problem!!

We stop deviceshare, (incl remove it with install delete) but when we start again, the drive is locked again.

I will attach some screenprints.
7 REPLIES
labadie_1
Honored Contributor

Re: locked tape device

Hello

Welcome to the Vms forum !

You have not stated the architecture (Vax, Alpha, Itanium), the Vms version (i.e 6.2, 7.3-2, 8.3 ...), the patches applied ($ prod sh prod, prod sh hist, dir/dat/siz sys$help:*.rel*), if you are in a Cluster (is this tape drive owned by a process on another member of the Cluster) ?

Do you have a process in the state Rwast ?

Have you tried to power-cycle the tape ?

What is the value oh the sysgen parameter mvtimeout ?
$ mc sysgen sh mvtimeout

If your process is in Rwast state, have a look at
http://www.pottsoft.com/home/vms/rwast.html

A reboot will solve the problem, but I guess you are trying to avoid it :-)

FrenkyBee
Occasional Visitor

Re: locked tape device

I'va paste the answers in a attachment.
labadie_1
Honored Contributor

Re: locked tape device

Thanks

$ set term/wid=132
$ prod sh hist

will show your patches level.

By the way, if you upgrade to 7.3-2, you will be supported, as 7.3 is no longer supported.
FrenkyBee
Occasional Visitor

Re: locked tape device

I know, but soon there will be a migration project; VMS 7.3-2 and ohter hardware.


Ian Miller.
Honored Contributor

Re: locked tape device

I'm guessing you are using this product

http://www.advsyscon.com/products/deviceshare/

Have you contacted Advanced Systems Concepts, Inc.?
____________________
Purely Personal Opinion
labadie_1
Honored Contributor

Re: locked tape device

In a recent thread, Hoff talked about a file your support center can provide (if it applies to your Vms version)

There's an old CSCPAT tool CSCPAT_0245_USE_WITH_CAUTION_MTDISMOUNT.EXE

See the thread "deleting a non-existent process".

Hoff
Honored Contributor

Re: locked tape device

You've probably hit one of a set of old and known bugs, and one of a set of bugs that have largely been fixed in newer OpenVMS releases.

This case was a very common error in older releases, and is rather more rarely seen on current releases.

Rebooting will be the fastest way to clear this.

As for upgrading to V7.3-2, I'd encourage upgrading all the way to V8.3; to the most current release. V7.3-2 is itself getting very old, and it's clear that your site has a history of staying on a particular release for a long time. Accordingly, getting as close to current when your site does upgrade is my recommendation.

As for the usual concerns around upgrading here, for all intents and purposes, the V8.* releases are not a major upgrade on OpenVMS Alpha, as compared to V7.3-2 and prior.

You might have a shot of fixing this case in situ with ECOs, as various releases saw ECOs for related issues.

The other common trigger is the use of SHARE privilege to share a device, and accompanied with an out-of-order device deallocation.

If you do decide to reboot to clear this case, this can be an opportunity to apply the current ECOs for V7.3, too.

The tool I mentioned in that other cited reply basically bombs the device ownership field. It's a work-around for various of the underlying dangling ownership issues in the older releases. That'll take ECOs or an upgrade.