Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

mySQL on Integrity

SOLVED
Go to solution
ptrskg
Frequent Advisor

mySQL on Integrity

Hi,

I am trying to install MYSQL051 V46.3-0 on OpenVms I64 8.4 but need zLib binaries to be successful.

Does anybody know where to find a suitable distribution?

Thanks,

Peter

5 REPLIES
Duncan Morris
Honored Contributor
Solution

Re: mySQL on Integrity

Hi Peter,

 

try:

 

 http://www.vsm.com.au/ftp/jfp/kits/

 

Jean-François PIÉRONNE has done a lot of good work with these kits.

 

Duncan

ptrskg
Frequent Advisor

Re: mySQL on Integrity

Thanks a lot!
Peter
Maurizio De Tommaso_
Frequent Advisor

Re: mySQL on Integrity

An extract of the MySQL V5.1-46 installation manual for OpenVMS :

 

Itanium platform

  • OpenVMS 8.3
  • patch VMS83I_ICXXL V0300 minimum on Itanium
  • HP SSL 1.4
  • Zlib V1.2.3 may be installed before MySQL but this is not mandatory as starting from MySQL 5.1.22 the MySQL kit include this library.

 

BTW, you can get the library from the following link :

 

http://www.vmspython.org/anonymous/kits/IA64/

 

I hope this helps,

/Maurizio

Steven Schweda
Honored Contributor

Re: mySQL on Integrity

   With a little fooling around, a normal zlib source kit can be built
on VMS.  In the zlib 1.2.5 kit, a type cast may be helpful:

ALP $ gdiff gzwrite.c_orig gzwrite.c     
324c324
<     len = vsprintf(state->in, format, va);
---
>     len = vsprintf( (char *)state->in, format, va);

And the DCL procedure make_vms.com has some goofy junk in it, and some
portability problems:

ALP $ gdiff make_vms.com_orig make_vms.com
19c19
< $ set proc/parse=ext
---
> $!!! set proc/parse=ext  !!! 2011-02-17 SMS.  Not much good on VAX.
124a125,126
> $ write aconf ""
> $ write aconf "/* VMS specifics added by make_vms.com: */"
134a137,139
> $ write aconf "#if defined( __VAX) || (__CRTL_VER < 70312000)
> $ write aconf "# define NO_vsnprintf
> $ write aconf "#endif"
423c428,429
<               link $(LOPTS) minigzip,libz.olb/lib,x11vms:xvmsutils.olb/lib
---
>               link $(LOPTS) minigzip,libz.olb/lib
> #### ,x11vms:xvmsutils.olb/lib

 


      http://zlib.net/

   I see that there's a 1.2.6 now, which, at first glance, appears to be
in worse shape.

Steven Schweda
Honored Contributor

Re: mySQL on Integrity

>    I see that there's a 1.2.6 now, which, at first glance, appears to be
> in worse shape.

   For a less hopeless VMS builder for the zlib 1.2.6 kit, and the minor
code change described above (type cast for warning reduction on old
systems):

      http://antinode.info/ftp/zlib/zlib-1_2_6/