Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

networking does not start up automatically at boot time

Shawn Adams_2
Occasional Visitor

networking does not start up automatically at boot time

Networking doesn't start up automatically at boot time on OpenVMS 7.3. How do I get tcpip to start automatically?
8 REPLIES
Antoniov.
Honored Contributor

Re: networking does not start up automatically at boot time

Edit SYS$MANAGER:SYSTARTUP_VMS.COM

If you have decnet IV
search STARTNET and remove remark from @STARTNET

If you have decnet-plus (decnet osi)
search start/network decnet and remove remark

Remark are line beginning with $!, remove exclamation point and leave dollar.

Cheers
Antonio Vigliotti
Antonio Maria Vigliotti
Volker Halle
Honored Contributor

Re: networking does not start up automatically at boot time

Shawn,

and to get TCPIP starting automatically, remove '$!' from the following line in SYSTARTUP_VMS.COM:

$!$ @SYS$STARTUP:TCPIP$STARTUP.COM

Startup command templates for other TCPIP products are also included in SYSTARTUP_VMS.COM

Volker.
Shawn Adams_2
Occasional Visitor

Re: networking does not start up automatically at boot time

Thanks so very much.
commenting out

$!$ @SYS$STARTUP:TCPIP$STARTUP.COM

worked great.
Jan van den Ende
Honored Contributor

Re: networking does not start up automatically at boot time

Shawn,

Welcome to the VMS forum!.

As you have just experienced, this is THE place for any questions more-or-less related to VMS, and the community is usually quick to try and help you.

May I invite you to read
http://forums1.itrc.hp.com/service/forums/helptips.do?#28
and then award Antonio some points, and Volker the 'right on target' 10 ?

It usually is also well-invested time to scan trough the forum. You will probably find answers to issues you did not even realise there were solutions for!
And of course, don'nt hesitate to ask any questions you might encounter!

Happy foruming,

Jan
Don't rust yours pelled jacker to fine doll missed aches.
Mobeen_1
Esteemed Contributor

Re: networking does not start up automatically at boot time

Shawn,
Make sure that you uncomment the line which says $! @sys$startup:tcpip$startup.com in the VMS startup file sys$startup:systartup_vms.com as many have
already suggested.

Simply u would need to do the following

1. Login and set default to sys$startup
$set def sys$startup:

2. Edit file sys$startup:systartup_vms.com
and modify the following line
$!@sys$startup:tcpip$startup.com
to
$ @sys$startup:tcpip$startup.com

3. If you don't find the above mentioned
line in the systartup_vms file, then
simply add that line and save this file

regards
Mobeen
Willem Grooters
Honored Contributor

Re: networking does not start up automatically at boot time

Antonio,


If you have decnet-plus (decnet osi)
search start/network decnet and remove remark


I thought this is obsolete since 7.something?, DECNet starts quite eraly in the startup proces (even when not activated..)
Or am I mistaken?

Willem
Willem Grooters
OpenVMS Developer & System Manager
Antoniov.
Honored Contributor

Re: networking does not start up automatically at boot time

Willem,
I'm not sure about this. In my testing system, V7.3-2 I installed DecNet phase IV and Decnet plus doesn't start. I opened e thread about this, because I can't install Advanced Server V7.3 ECO3.
I guess DecNet plus starts if license found on system but next days I'try what will happen.

Cheers
Antonio Vigliotti
Antonio Maria Vigliotti
Volker Halle
Honored Contributor

Re: networking does not start up automatically at boot time

Antonio,

you can install either DECNET_PHASE_IV or DECNET_OSI (also called DECnet-Plus).

DECnet-Plus (aka NCL) will be started automatically from SYS$SYSTEM:STARTUP.COM, DECnet-Phase IV (aka NCP) needs either START/NETWORK DECnet or @SYS$STARTUP:STARTNET invoked in SYSTARTUP_VMS.COM

Volker.