Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

samba&winbind issue

liucheng_720
Occasional Visitor

samba&winbind issue

I have one problem about samba&winbind on OpenVMS system.

As we known, WINBIND will provided  Automatic user mapping. It means if an user exist in windows domain but dont exist in open vms system, winbind will auto create a mapping account like CIFS$user on vms system. But in my situation, it cannot auto create CIFS$user.(If the OpenVMS username and the windows domain username are identical, user can access the shared folder,that means samba is OK) Please help to check why.

 

The attachment is SMB.CONF and log file. I dont think this problem caused by configuration file, because we have another server, use almost the same configure file (different domain), there is no problem.

 

And below is the samba start log.

$ smbstart

[ Creating NMBD Process... ]

%RUN-S-PROC_ID, identification of created process is 0004D94F 

[ Enabling SMBD services... ]

[ Successfully enabled TCPIP SMBD services. ]

 

Thanks very much!!

1 REPLY

Re: samba&winbind issue

Hi,

 

we have no problems with winbind and just use configuration information like this...

 

   idmap uid = 10000-20000
   idmap gid = 10000-40000
   winbind enum users = no
   winbind enum groups = no
   winbind use default domain = Yes

We are using security = ADS but winbind was working fine when we just used security=domain as well.

I guess you've chosen valid user and group ranges - that is, ranges that are free or have no user or group already?

 

What happens if you do a

 

wbinfo "-g"

 

command at the dcl prompt? It should show all of your domain's groups.

 

This is on a IA64 8.3 cluster and also a IA64 8.4 standalone system

 

Cheers,

 

Mark