Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

setting time im VMS

 
SOLVED
Go to solution
Vogra
Regular Advisor

setting time im VMS

Hi all,

how can I set time in vms 7.2-1?
exactly command please,
Lima.
We are spirits in the material world
7 REPLIES 7
Volker Halle
Honored Contributor
Solution

Re: setting time im VMS

Hi,

to set the time and date in OpenVMS, use the SET TIME command. See HELP SET TIME

$ SET TIME=17-OCT-2005:13:00:00

Volker.
Daniel Fernandez Illan
Trusted Contributor

Re: setting time im VMS

Hi
you can also use:
SET TIME="17-oct-2005 16:33"
or
SET TIME=" + 01:00 "
to increase un hour the current time.
Saludos.
Daniel.
Arch_Muthiah
Honored Contributor

Re: setting time im VMS

Hi vogra,

DAYLIGHT saving!

$ @SYS$EXAMPLES:DAYLIGHT_SAVINGS.COM

Run this procedure to adjust the system time and TDF (time differential factor) automatically twice a year.


Archunan
Regards
Archie
Mike Reznak
Trusted Contributor

Re: setting time im VMS

Hi,

command set time is not enabled, when UCX DTSS or TCPIP NTP service for time synchronization is running. Then you have use UTC$TIMEZONE_SETUP.COM or disable service for a while.

Mike
...and I think to myself, what a wonderful world ;o)
Volker Halle
Honored Contributor

Re: setting time im VMS

re: Mike,

you still can use SET TIME if TCPIP NTP is running, but you can't use this command when running DECnet-Plus DTSS.

If it's necessary to set the time while running DTSS, you need to temporarily disable DTSS with:

$ MC NCL DISABLE DTSS
$ MC NCL DELETE DTSS
$ SET TIME=...
$ @SYS$STARTUP:DTSS$STARTUP

Volker.
Sebastian Bazley
Regular Advisor

Re: setting time im VMS

[Just happened across the following today.]

If you want to adjust the time in a cluster, you can use the following command:

MCR SYSMAN
SYSMAN> SET ENVIRON/CLUSTER
SYSMAN> CONFIG SET TIME dd-MMM-yyyy hh:mm:ss
SYSMAN> EXIT

This will ensure all the nodes use the same time as far as possible.

Have a look a SYSMAN HELP CONF SET TIME

and particularly:

SYSMAN> HELP CONF SET TIME DESC
...
As a result of slight inaccuracies in each processor clock,
times on various members of a cluster tend to drift apart.
The following procedure synchronizes system times in a cluster
environment:

$ SYNCH_CLOCKS:
$ RUN SYS$SYSTEM:SYSMAN
SET ENVIRONMENT/CLUSTER
CONFIGURATION SET TIME
EXIT
$ WAIT 6:00:00
$ GOTO SYNCH_CLOCKS

The procedure sets the time on all cluster nodes to the value
obtained from the local time-of-year clock, waits 6 hours, then
resets the time for the cluster.

This won't work if DTSS is being used, but in that case there's no need to synch clocks anyway.
Highlighted
Anton van Ruitenbeek
Trusted Contributor

Re: setting time im VMS

To keep the time in the cluster between the nodes aligned you can also setup NTP services on all the nodes, and let all the nodes look at eachother. Make sure that one (or better all) nodes have an external synch.
Modify TCPIP$NTP.CONF with the correct STRATUM for eacht node and if possible external nodes.
Startup NTP and check it with eq. ntpq -c peer

Problem we had this weekend, 4 node cluster, DAYLIGHT_SAVING was set to 1 as on alle the nodes. This system didn't modify the time during the switch this weekend. Other nodes, not cluster(members), using the same configuration (timezone rules, sysgen paras etc) did it correct this weekend. I'm not sure what cased this.
Unfortunaly we don't use DTSS anymore. (That was working fine, so don't use it :( ! )

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !