Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

tcp/ip telnet issue

 
rick agostino
Occasional Advisor

tcp/ip telnet issue

I currently have an issue with a node where I cannot to itself or to any other node.

The following error appears when trying to telnet out or to itself

%TELNET-E-IVHOST, Invalid or unknown host localhost
-TCPIP-W-EAI_AGAIN, temporary failure

The strange thing is I can telnet into the box from outside.

The node was added into an existing cluster so cannot see this issue being a TCP/IP or O/S version/patch issue.

Any ideas????
13 REPLIES 13
Steven Schweda
Honored Contributor

Re: tcp/ip telnet issue

> [...] Invalid or unknown host localhost

So, what does "tcpip show host localhost"
say? Around here:

ALP $ tcpip show host localhost

LOCAL database

Host address Host name

127.0.0.1 LOCALHOST, localhost, LOOPBACK, me

At least some of that should be there. (The
"me" part is optional.)
rick agostino
Occasional Advisor

Re: tcp/ip telnet issue

LOCAL database

Host address Host name

127.0.0.1 LOCALHOST, localhost
Highlighted
marsh_1
Honored Contributor

Re: tcp/ip telnet issue

rick,

what version of vms and ip stack is this ?
have any changes been made recently and does it work with an ip address as opposed to a host name ?

Hoff
Honored Contributor

Re: tcp/ip telnet issue

IP stack and version and OpenVMS architecture and version?

Could you elaborate on the cluster environment and on how the new system was added to the cluster?

Was the particular IP stack configured subsequent to the OpenVMS and (it looks like) TCP/IP Services installation, and was the telnet client started?

Forgetting to invoke TCPIP$CONFIG (assuming V5.0 or later of TCP/IP Services) and adding the required clients and servers causes weird errors, for instance.
Martin P.J. Zinser
Honored Contributor

Re: tcp/ip telnet issue

Have you tried skipping the name resolution part, i.e. not "telnet localhost" but telnet 127.0.0.1 (or any other address on your network with a working telnet server).

Greetings, Martin
rick agostino
Occasional Advisor

Re: tcp/ip telnet issue

Running OpenVMS V7.3-2 and HP TCP/IP Services for OpenVMS Alpha Version V5.4 ECO 6

Cannot telnet to IP address or Hostname.

The system was added to the cluster via sys$manager:cluster_config procedure.

IP stack was configured using sys$manager:tcpip$config and TELNET is enabled.



cannot telnet "localhost" or 127.0.0.1


telnet localhost
%TELNET-E-IVHOST, Invalid or unknown host localhost
-TCPIP-W-EAI_AGAIN, temporary failure

telnet 127.0.0.1
%TELNET-E-IVHOST, Invalid or unknown host 127.0.0.1
-TCPIP-W-EAI_AGAIN, temporary failure

tcpip show host localhost

LOCAL database

Host address Host name

127.0.0.1 LOCALHOST, localhost

marsh_1
Honored Contributor

Re: tcp/ip telnet issue

rick,

do you have tcpip$inet_host defined and a corresponding entry in the host table ?

marsh_1
Honored Contributor

Re: tcp/ip telnet issue

rick,

have any of the interfaces been reconfigured recently ?

rick agostino
Occasional Advisor

Re: tcp/ip telnet issue

Mark,

yes logical exists and entry is in the host table

TCPIP$INET_HOST" = "HTV009"(LNM$SYSTEM_TABLE)

10.8.200.58 HTV009

The server is a new machine added to exiting cluster so all interfaces were configured after cluster config was completed and server booted.