Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

tcpip$inet_host

SOLVED
Go to solution
robert70
Valued Contributor

tcpip$inet_host

Have an Alpha system and an Integrity system RX2800 - both are configured with IP addresses and can telnet ftp to both no problem  - why is the integrity not showing anything in its TCPIP$INET logicals? Do i need to configure something further?

 

Alpha - HP TCP/IP Services for OpenVMS Alpha Version V5.6 - ECO 5
  on a COMPAQ AlphaServer DS20E 666 MHz running OpenVMS V8.3

 

$ CHAS:SYSTEM> sh log tcpip$inet*

(LNM$PROCESS_TABLE)

(LNM$JOB_82120280)

(SERVER_2010591652)

(LNM$GROUP_000001)

(LNM$SYSTEM_TABLE)

  "TCPIP$INET_DOMAIN" = "chasdomain"
  "TCPIP$INET_HOST" = "CHAS"
  "TCPIP$INET_HOSTADDR" = "129.94.185.45"

(LNM$SYSCLUSTER_TABLE)

(DECW$LOGICAL_NAMES)

 

Integrity - HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.7 - ECO 2
  on an HP Integrity rx2800 i2  (1.33GHz/4.0MB) running OpenVMS V8.4

 

$ sho log tcpip$inet*

(LNM$PROCESS_TABLE)

(LNM$JOB_8939C580)

(LNM$GROUP_000001)

(LNM$SYSTEM_TABLE)

(LNM$SYSCLUSTER_TABLE)

(DECW$LOGICAL_NAMES)
%SHOW-S-NOTRAN, no translation for logical name TCPIP$INET*

 

 

 

12 REPLIES
Maurizio De Tommaso_
Frequent Advisor

Re: tcpip$inet_host

what about the output of the following command on Integrity side ?

 

$ Show Network

 

/Maurizio

robert70
Valued Contributor

Re: tcpip$inet_host

$ show network

Product: DECNET Node: EDDY Address(es): 63.1020
Product: TCP/IP Node: <TCP/IP host/node name not yet available> Address
(es): 0.0.0.0
Maurizio De Tommaso_
Frequent Advisor

Re: tcpip$inet_host

So It seems that your TCP/Ip Stack is not configured or/and it is not yet started on Integrity side.

Are you sure that you are referencing to the correct system on your network via Ip ?

 

To check if the interfaces of your Integrity server are correctly configured :

 

$ TCPIP sho conf interf    ! Info from Permanent Database

 

then

 

$ ifconfig -a                        ! Info from Volatile database

 

Please, post the output of the above commands.

 

/Maurizio

 

 

robert70
Valued Contributor

Re: tcpip$inet_host

$ TCPIP sho conf interf

Interface: LO0
IP_Addr: 127.0.0.1 NETWRK: 255.0.0.0 BRDCST:

Interface: IE1
IP_Addr: NETWRK: BRDCST:

Interface: IE2
IP_Addr: NETWRK: BRDCST:

Interface: IE3
IP_Addr: NETWRK: BRDCST:

Interface: IE0
IP_Addr: 129.94.185.40 NETWRK: 255.255.255.128 BRDCST: 129.94.185.127


$ ipconfig -a
%DCL-W-IVVERB, unrecognized command verb - check validity and spelling
\IPCONFIG\
robert70
Valued Contributor

Re: tcpip$inet_host

$ ifconfig -a
%DCL-W-IVVERB, unrecognized command verb - check validity and spelling
\IFCONFIG\
robert70
Valued Contributor

Re: tcpip$inet_host

TCPIP> netstat -rn
Routing tables
Destination Gateway Flags Refs Use Interface

Route Tree for Protocol Family 26:

Route Tree for Protocol Family 2:
default 129.94.185.1 UGS 0 0 IE0
127.0.0.1 127.0.0.1 UHL 10 43 LO0
129.94.185.0/25 129.94.185.40 U 5 208 IE0
129.94.185.13 129.94.185.1 UGHS 0 0 IE0
129.94.185.40 129.94.185.40 UHL 1 16 IE0
129.94.185.46 129.94.185.1 UGHS 0 0 IE0
Maurizio De Tommaso_
Frequent Advisor

Re: tcpip$inet_host

You need to define tcpip symbols before to use the "Unix style commands":

 

$ @sys$manager:tcpip$define_commands

$ ifconfig -a

 

please, post also the ouptut of :

 

$ tcpip sho conf comm

 

/maurizio

robert70
Valued Contributor

Re: tcpip$inet_host

$ $ ifconfig -a
IE0: flags=c43<UP,BROADCAST,RUNNING,MULTICAST,SIMPLEX>
*inet 129.94.185.40 netmask ffffff80 broadcast 129.94.185.127 ipmtu 1500

IE1: flags=c23<UP,BROADCAST,NOTRAILERS,MULTICAST,SIMPLEX>

IE2: flags=c23<UP,BROADCAST,NOTRAILERS,MULTICAST,SIMPLEX>

IE3: flags=c23<UP,BROADCAST,NOTRAILERS,MULTICAST,SIMPLEX>

LO0: flags=100c89<UP,LOOPBACK,NOARP,MULTICAST,SIMPLEX,NOCHECKSUM>
inet 127.0.0.1 netmask ff000000 ipmtu 4096

TN0: flags=80<NOARP>

TN1: flags=80<NOARP>



$ $ tcpip sho conf comm

Communication Configuration

Local host: eddy.ho.test.uk.testDomain: test

Cluster timer: 0

Interfaces: 0 Type: Default
Device_sockets: 0
Routes: 0
Services: 0
Proxies: 0

Free Maximum Minimum
Large buffers 0 0 0
Small buffers 0 0 0
IRPs 0 0
Non TCPIP buffers 0

Remote Terminal
Large buffers: 0
UCBs: 0
Virtual term: disabled
$
$
Maurizio De Tommaso_
Frequent Advisor
Solution

Re: tcpip$inet_host

Basing on your output it results :

 

Local host: eddy.ho.test.uk.test

Domain: test

 

It should be, for example :

 

Local host: eddy

Domain: acme.com

 

Try this procedure (If there isn't a text formatting error in your post) :

 

$ tcpip set conf comm /Domain=acme.com  /Local=eddy

$ tcpip set comm /Domain=acme.com /Local=eddy

 

then restart your ip stack

 

$ @sys$startup:tcpip$shutdown

$ @sys$startup:tcpip$startup

 

/Maurizio



 

robert70
Valued Contributor

Re: tcpip$inet_host

maurizio thanks
thats done it now getting


$ sh log tcpip$inet*

(LNM$PROCESS_TABLE)

(LNM$JOB_895C7240)

(LNM$GROUP_000001)

(LNM$SYSTEM_TABLE)

"TCPIP$INET_DOMAIN" = "ACME.COM"
"TCPIP$INET_HOST" = "eddy"
"TCPIP$INET_HOSTADDR" = "129.94.185.40"

(LNM$SYSCLUSTER_TABLE)

(DECW$LOGICAL_NAMES)

many thanks for your help
Maurizio De Tommaso_
Frequent Advisor

Re: tcpip$inet_host

Domain "acme.com" was reported in my post only as example.

 

in case, setup the domain name more appropriate for your site.

 

Best regards,

/Maurizio

robert70
Valued Contributor

Re: tcpip$inet_host

already done - thanks