Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

upgrade vms 7.3-2 to 8.3 problems

 
SOLVED
Go to solution
robert70
Valued Contributor

upgrade vms 7.3-2 to 8.3 problems

I have upgraded a DS20E which was running VMS 7.3-2 (TCPIP V5.4) to VMS 8.3 (TCPIP V5.6-9ECO5).
The 8.3 is patched with the UPDATE-1200 patch kit.

The upgraded server is on our LAN here and while previously we could PING/FTP/TELENT to our other ALpha Server - this is no longer working?

Any obvious patches I have missed?

Regards
Roger

38 REPLIES 38
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

is TCPIP running ? Is there a TCPIP interface ?

$ TCPIP SHOW INT

Does $ TELNET LOCALHOST work ? And $ TCPIP PING LOCALHOST ?

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

TCPIP is running yes
I can PING & TELNET to localhost yes


$ tcpip show int

Interface IP_Addr Network mask Receive Send MTU

IE0 129.94.185.46 255.255.255.128 283 20 1500
LO0 127.0.0.1 255.0.0.0 216 216 4096

Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

can you ping the default gateway (find it with TCPIP SHOW ROUTE and the gateway address for AN 0.0.0.0) ?

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Not sure what you mean here sorry.

I think our gateway is 129.94.185.1
but I cant ping that.
When i do a show route I get lots of routes with the gateway on the right hand column all showing 129.94.185.1.
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

the default gateway should also be visible with TCPIP SHOW ROUTE/PERM.

Check the LAN interface counters with

$ MC LANCP SHOW DEV/COUNT EIA

And check for any LAN driver messages with

$ MC LANCP SHOW DEV/INT EIA

Does ARP work and return the MAC addresses of IP nodes on your network ?

$ @SYS$MANAGER:TCPIP$DEFINE_COMMANDS
$ ARP -a

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

ARP returns this on our upgraded system....

CHAS.chasdomain (129.94.185.45) at (incomplete)

We are also experiencing problems with our LIVE box when this newly upgraded box is on the network. In particular users connecting with Pathworks are losing there mapped shares. Incidentally the Upgraded Server has no pathworks installed.

Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

same IP address on more than 1 system ? Or same MAC address (DECnet) ?

Volker.
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

easiest way to check MAC address is:

$ SHOW DEV/FULL EIA0 (on V8.3)

$ ANAL/SYS
SDA> SHOW LAN/FULL/DEV=EIA (on V7.3-2)

When DECnet starts and you're running DECnet Phase IV or DECnet-OSI with Phase IV compatible address, it changes the MAC address of the LAN interface to AA-00-04-00-xx-yy (with xx-yy being set based on the DECnet address)

Does $ SHO NET show the same DECnet address on your LIVE and upgraded system ?

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

$tcpip show route/perm

on both LIVE server and UPGRADED server we have:-

PN 0.0.0.0 128.64.32.1

The 128.64.32.1 is an old IP address which we havent been using for about 5 years.
We now use 129.94.185.1

IS this a problem area? The fact that the LIVE server is working with this?
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

on LIVE box we have

SDA> show lan/full/dev=eia

LAN Data Structures
-------------------
-- EIA Device Information 26-MAR-2010 10:50:38 --

LSB address 837E2000 Driver code address 00000000
Driver version 00A50001.07320029 Device1 code address 00000000
Device1 version 00000000.00000000 Device2 code address 00000000
Device2 version 00000000.00000000 LAN code address 811FF400
LAN version 00A50001.07320156 DLL type CSMACD
Device name EI_82558 MOP name EIA
MOP ID 204 HW serial Not supplied
HW version 12298086 Promiscuous mode OFF
Controller mode NORMAL Promiscuous UCB 00000000
Internal loopback OFF All multicast state OFF
Hardware address 00-02-A5-60-4B-E8 CRC generation mode ON
Physical address AA-00-04-00-FE-FF Full Duplex Enable ON
Active unit count 4 Full Duplex State ON
Line speed 100

Flags: 00000140
Char: 00000004 MULSEG

Press RETURN for more.
SDA>


On Upgraded box we have...............

Def. MAC addr 00-02-A5-60-61-1E
Current MAC addr AA-00-04-00-FE-FF

Is this the problem? current MAC on UPGRADE is same as Physical address on LIVE box?
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

as long as you don't communicate with IP addresses outside your current IP network (129.94.185.128), the default gateway will not be used. This could explain, why this wrong config still works.

You should correct his with:

$ TCPIP SET NOROUTE/DEFAULT/PERM

and then run @TCPIP$CONFIG to define the correct route.

Volker.
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

YES, this IS THE PROBLEM: AA-00-04-00-FE-FF

You now have 2 systems with the same active MAC address on your LAN segment. First thing to do: disconnect the network cable of the upgraded system !!!

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

thanks - Ive had the UPGRADE box disconnected for sometime - as was causing problems with our LIVE box.
How do I resolve the problem with the UPGRADE mac address?
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

is it the scssytemid in the modparams that is the problem here?
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

let me guess: you've taken an image backup of your LIVE box and upgraded that to V8.3. You thought about the different IP addresses, but you didn't think about DECnet ...

You need to change the DECnet address of the upgraded system to a new UNIQUE DECnet address. How to do this depends on your DECnet version and what your plans are to replace/upgrade your LIVE system.

If you're running DECnet-Plus (DECNET_OSI), then just editing SYS$MANAGER:NET$ROUTING_STARTUP.NCL and changing the PHASEIV ADDRESS may be sufficient.

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

we dont run decnet on either box - we use pathworks on our LIVE box but have pathworks switched off on our UPGRADE box.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Yes it was an image backup of LIVE box with changes to the NODE name and IP address.
The scssytemid in modparmas.dat is not the same as the LIVE box so not sure why the MAC addresses are showing the same?
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

if the MAC address is a DECnet MAC address, you ARE running DECnet.

$ SHOW SYS/PROC=NET*

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

nothing returned with
$ show sys/proce=net*
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

typo used proc without the e!
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

AA-00-04-00-FE-FF maps to DECnet address 63.1022 or 65535 in decimal notation (like in SCSSYSTEMID).

What does $ SHOW NET report ?

Volker.
Volker Halle
Honored Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

Roger,

now that's my typo: 63.1022 or 65534 in decimal !

Volker.
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

in modparams.dat the scssystemid is set to 65533 - I ran AUTOGEN and reboot.
The MAC address is still showing AA-00-04-00-FE-FF

SHOW NET

Product: TCP/IP Node: DAVE.DAVEDOMAIN Address(es): 129.94.185.46
robert70
Valued Contributor

Re: upgrade vms 7.3-2 to 8.3 problems

I also notice that the ALPHAVMSSYS.PAR file which I believe holds the SCSNODE and SCSSYSTEMID has not changed since yesterdays upgrade - does this mean that my AUTOGEN and reboot are not actually updating the SCSSYTEMID after all?