Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

5.1B user account migration from 5.1A

SOLVED
Go to solution
Kevin Raubenolt
Occasional Visitor

5.1B user account migration from 5.1A

I am creating a new 5.1B cluster and want to export all my users and their passwords to the new cluster. I tried:
5.1A Cluster> edauth -g > /tmp/users.txt

5.1B Cluster> edauth -C < /tmp/users.txt
Missing list of entry names to edit

Any ideas?

Thanks.
Kevin
3 REPLIES
Hein van den Heuvel
Honored Contributor
Solution

Re: 5.1B user account migration from 5.1A

Don't you need -s on the import command line?

Mind you, prior to reading this entry and dong a man edauth I expected migrating users to amoutn to copying /etc/passwd to the new box :-). That's what we do in our labs. admittedly those are a far cry from a secure production environment.

hth,
Hein.
Ralf Puchner
Honored Contributor

Re: 5.1B user account migration from 5.1A

it depend on the used security mechanism. Please let us know what kind of security is enabled - C2 or base?

If it is base, copy the /etc/passwd and /etc/group file, recreate the home directories on the new machine and be sure links and CDSL's are valid. Remove /etc/passwd.dir and .pag file if exists.

For C2 security you must use the edauth and C2 tools. Why not using NIS/YP to share user/groups if using different machines?



Help() { FirstReadManual(urgently); Go_to_it;; }
Kevin Raubenolt
Occasional Visitor

Re: 5.1B user account migration from 5.1A

I have it resolved.

I was using C2 security (enhansed). The problem was two:

1. I copied /etc/group across to the new cluster.
2. I used edauth -s < /tmp/users.txt

Everything then worked.

Thanks for the replies.