Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

ADVFS : Domain domain1 not activated

SOLVED
Go to solution
Danny Ramos_3
Occasional Contributor

ADVFS : Domain domain1 not activated

hi guys,

am currently having problem mounting one of my domains. I've tried the following:

showfdmn domain1: (below is the output)

"# showfdmn domain1
ADVFS : Domain domain1 not activated - inconsistency detected
showfdmn: unable to get info for domain 'domain1'
showfdmn: error = E_DOMAIN_NOT_ACTIVATED (-1067)
#"

i tried to list the domain attributes, and found that each of the disk devices within the domain contains an advfs partition (using disklabel). unfortunately, nothing went right! i also made use of advscan to no avail.


--------------------------------------------
i'm using an old AS4100 with tru64 ver 4.0f, below is the error messages from messages prior to halting.


Apr 15 15:31:22 PROSPERO1 vmunix: ADVFS INTERNAL ERROR: dealloc_bits_page: can't clear a bit twice!
Apr 15 15:31:22 PROSPERO1 vmunix: ADVFS: dmnId = 3f3fa934.00047b7b, vd = 1, pg = 19, wd = 705, mask = 00000000
Apr 15 20:39:06 PROSPERO1 vmunix: ADVFS EXCEPTION
Apr 15 20:39:06 PROSPERO1 vmunix: Module = bs_sbm.c, Line = 330
Apr 15 20:39:06 PROSPERO1 vmunix: ADVFS INTERNAL ERROR: dealloc_bits_page: can't clear a bit twice!
Apr 15 20:39:06 PROSPERO1 vmunix:
Apr 15 20:39:06 PROSPERO1 vmunix: panic (cpu 2): ADVFS INTERNAL ERROR: dealloc_bits_page: can't clear a bit twice!
Apr 15 20:39:06 PROSPERO1 vmunix:

highly appreciate your response thanks.

danny
2 REPLIES
Mark Poeschl_2
Honored Contributor
Solution

Re: ADVFS : Domain domain1 not activated

Have you tried running the 'verify' or failing that the 'salvage' command against the domain? Try 'verify' first. With the '-f' flag it will attempt to fix certain types of corruptions in a domain. If 'verify' doesn't work, you may still be able to use 'salvage' to recover some or all of your data.
Greg Yates
Valued Contributor

Re: ADVFS : Domain domain1 not activated

Danny,

You normally get that panic because of storage problems (disk going bad, etc.). If you haven't already gotten the domain mountable) we could get you the latest fixfdmn and/or the latest version of salvage. Please log a support call if you still need help.

Thanks.
Greg