Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Added users cannot login in telnet

Michael P. Carel
Occasional Visitor

Added users cannot login in telnet

Hi to all,

I used to add users using "adduser" but they cannot login via telnet. The telnet session automatically disconnect after entering the password.

Any idea why this happend? Im using Tru64 V.5


Thanks in advance for any help.


Mike
10 REPLIES
Ravi_8
Honored Contributor

Re: Added users cannot login in telnet

Hi Mike

is the string "ptys" added at the end of the file /etc/securettys.

is the license expired?
never give up
Eric van Dijken
Trusted Contributor

Re: Added users cannot login in telnet

What do your logfiles tell you?

(The files /usr/adm/syslog.dated/current/ are a good starting point.)

Did you enable enhanced security?

Are the accounts "enabled" or "locked"?

(Check with "dxaccounts")


Watch, Think and Tinker.
Johan Brusche
Honored Contributor

Re: Added users cannot login in telnet


If it's only the newly added users, maybe there's a problem with their default .profile or .login that's been put in place. These are normally copies from the ones in /usr/skel/* .

JB.

_JB_
Michael P. Carel
Occasional Visitor

Re: Added users cannot login in telnet

how can i know that the license was expire, the user who used to log reports me something about "to many users login..." then disconnect them. I've tested the user accounts after my creation using adduser command but now this account doesnt work.

I've checked the securettys it has the ptys.

I'm just newbie in tru64 please help...
Johan Brusche
Honored Contributor

Re: Added users cannot login in telnet

Mike,

To see the license useage use the command:
lmf list

JB.

_JB_
Michael P. Carel
Occasional Visitor

Re: Added users cannot login in telnet

I've attached the output of my machine license, i've seen alot of terminated and active status for which i dont know which of them affects the logins of my users. Only root can login in telnet and can change users while root the root shell.
Is it ok to use the "adduser" command in adding/creating users? did i missed something during my users creation?

Please help...
Johan Brusche
Honored Contributor

Re: Added users cannot login in telnet


Although you seem to have an active-unlimited OSF-USR license, you do NOT have an OSF-BASE license, which is a prerequisite for the OSF-USR.

Your license db looks somewhat 'suspect' with all those terminated licenses, you can clean it up with a series of commands like:

1) lmf list full for TCR-UA
2) lmf delete TCR-UA DEC "Authorization nmbr"

The first command is to find the authorization number of the terminated license.

To correct he login problem, you should find the original paper document with the OSF-BASE license and enter it via the "lmf register" command.

Johan.

_JB_
Michael Schulte zur Sur
Honored Contributor

Re: Added users cannot login in telnet

Hi,

ptys in /etc/securettys is only important for root login.
If you do not have multiple licenses for one product then
lmf delete product
is enough to delete the license.
I would also look into /var/adm/messages and into the log files in /var/adm/syslog.dated/current especially auth.log
Do you get any error messages?
Does the user profile contain an exit?

greetings,

Michael
Mohamed K Ahmed
Trusted Contributor

Re: Added users cannot login in telnet

too many users logged in already means that you don't have enough OSF-BASE license units to run on the system.
Check the units required by your system, how many CPUs are there and how many units of OSF-BASE do you need/CPU
From my system (ES40 4 cpus), I know that I need 50 units of OSF-BASE/CPU, so I have 4 OSF-BASE each one is with 50 units and it works fine.
If I deleted one of them, I would receive the same message that you receive.

HTH

Mohamed
Ralf Puchner
Honored Contributor

Re: Added users cannot login in telnet

last posting is absolut correct, please verify license of machine or disable CPU's until the base licenses matches your configuration.
Help() { FirstReadManual(urgently); Go_to_it;; }