Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Alpha DS20 crashed after Patch Kit 5 installation

Kalin Tzenov
Occasional Advisor

Alpha DS20 crashed after Patch Kit 5 installation

After successful installation of PK5 for Tru64 v5.1B on a DS20 Alphaserver, the system didn't want to come up. Tried numerous times and always got the same:

CPU 0 booting

Resetting I/O buses...
(boot dga10300.1001.0.8.0 -flags A)
block 0 of dga10300.1001.0.8.0 is a valid boot block
reading 19 blocks from dga10300.1001.0.8.0
bootstrap code read in
base = 200000, image_start = 0, image_bytes = 2600(9728)
initializing HWRPB at 2000
initializing page table at 3ff42000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code

UNIX boot - Friday April 29, 2005

Loading vmunix ...
Loading at 0xfffffc0000230000

04:42:31 Sizes:
text = 7555328
data = 1509664
bss = 1909280
Starting at 0xfffffc0000242f00

Loading vmunix symbol table ... [1806488 bytes]
Memory trolling not supported, cpu Major id 13, Minor id 4
Alpha boot: available memory from 0x3026000 to 0x7fffc000
Compaq Tru64 UNIX V5.1B (Rev. 2650); Fri Mar 31 04:40:22 EST 2006
physical memory = 2048.00 megabytes.
available memory = 1975.63 megabytes.
using 7808 buffers containing 61.00 megabytes of memory

trap: invalid memory read access from kernel mode

faulting virtual address: 0x0000000000000000
pc of faulting instruction: 0xfffffc00006b4d94
ra contents at time of fault: 0xfffffc00002ea60c
sp contents at time of fault: 0xfffffe04a07374a0

panic (cpu 0): kernel memory fault


The only way out of it was to boot from another system disk and restore the /vmunix.PrePatch to /vmunix and then boot again.

This happened only on DS20. I have a bunch of 1200, 4100 and ES40 and everywhere else it worked like a charm.

Any ideas?

Thanks
4 REPLIES
Ivan Ferreira
Honored Contributor

Re: Alpha DS20 crashed after Patch Kit 5 installation

Have you tried booting genvmunix generating a new kernel again?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Kalin Tzenov
Occasional Advisor

Re: Alpha DS20 crashed after Patch Kit 5 installation

Yes, I've tried booting from /genvmunix, but it crashed again. PK5 changed /genvmunix too (I compared it with /genvmunix before the installation).
VINCENT, Jean-Marc
Valued Contributor

Re: Alpha DS20 crashed after Patch Kit 5 installation

Hi,

I am interested in getting at least the crash-data.? produced by savecore when the system finally boot with /vmunix.PrePatch.

You an mail me at jean-marc.vincent@hp.com

Regards,

VINCENT Jean-Marc
HP France
Groupe Support Unix
Tru64(tm) UNIX Technical Consultant - Tru64(tm) UNIX Ambassador HP France
+33 1 5762-8861
jean-marc.vincent@hp.com
Eden Torres Torres
Occasional Visitor

Re: Alpha DS20 crashed after Patch Kit 5 installation

Kalin,
How do you resolved this situation. I have the same with a DS25. I have installed in DS80, ES40 and ES45.
I need Patch Kit 5 for Oracle 9i.

Maybe you can give me a tip

Thanks in advanced

Edén Torres T
Tecnicard Inc.