Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

CDE settings on Tru64

SOLVED
Go to solution
Nguyen Anh Tien
Honored Contributor

CDE settings on Tru64

Pls help me to config X-client access to CDE on Tru64.
Now: I can telnet using root and nornal user to Tru64 server but cat not login via CDE.
What shoul I do???
HP is simple
7 REPLIES
Venkatesh BL
Honored Contributor

Re: CDE settings on Tru64

What is the error you get?

Did you try 'xhost +' on the server?
Nguyen Anh Tien
Honored Contributor

Re: CDE settings on Tru64

CDE returns
"root losysgin refused on this terminal"
non- root users can access via CDE but root can not.
HP is simple
Venkatesh BL
Honored Contributor

Re: CDE settings on Tru64

ok...I think your problem is due to lack of 'ptys' entry in the /etc/securettys file.

Check out the manpage of 'securettys' before applying the change.
Devesh Pant_1
Esteemed Contributor

Re: CDE settings on Tru64

I am not sure if you want root to directly do a login using CDE.

If you are okay with direct root logins from ptys ( pseudo terminals such as your PC with the CDE) then add the line /dev/ptys to the file
/etc/securettys and then root will be able to log on.

thanks
DP
郭尚中_1
Valued Contributor

Re: CDE settings on Tru64

Add ptys in the /etc/securettys just allow you connect Tru64 using root privilages. If you would like use CDE, add an IP address item of your PC to the file. It will allow you connect it using CDE.Examples is listed below. Also use command # xhost + to allow remote X windows.

/dev/console
local:0
:0
ptys:0
15.79.15.11:0


Regards!
Rick Retterer
Respected Contributor
Solution

Re: CDE settings on Tru64

Hello,
I work with the eXursion and CDE team in Atlanta. Here is what we recommend.

1) Attempt to connect to the system using a CDE login as root and let it fail once.

2) After the failed login as "root", simply telnet in as any user and then 'su' to root.

3) Change directory to /var/adm/syslog.dated/current then look at the "auth.log" file. Here you will see the failed "root" login attempt. You should either see the IP Hostname or IP address of the PC you attempted to connect in with.

Example:
Root Login Refused from terminal: ip.address.of.nt.system:0
-or-
Root Login Refused from terminal:
visual.alf.cpqcorp.net:0

4) Copy down the exact hostname -or- ip address used, and then change directory to /etc.

5) Then as the previous person stated, simply add the Hostname -or- IP address of the PC with a :0 (to indicate the server #) attached to the end of the line.

Note, if the pc is using a DHCP served address, and the IP address of the PC is seen in the "auth.log" file, this address could change and you may need to do this again on your next login. This all depends on if you have a dynamic DNS server setup in conjunction with DHCP so that PC's hostname is used each time. Then if the DHCP server assigns a new IP address to the PC the next time it is due to renew it, it won't affect it.

I hope I have been clear enough so as not to confuse you.

Good Luck!

Rick Retterer
HP Services
Atlanta, GA.
- Rick Retterer



Nguyen Anh Tien
Honored Contributor

Re: CDE settings on Tru64

Thank You. I found solution from your replies.
tienna
HP is simple