Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Error: Unresolved symbol in /usr/bin/pg: safe_open

Chanatip Laongsiriwong
Occasional Advisor

Error: Unresolved symbol in /usr/bin/pg: safe_open

After I install patch kit 4 on V4.0G
when run pg command have error.
8441:/usr/bin/pg: /sbin/loader: Error: Unresolved symbol in /usr/bin/pg: safe_open
8441:/usr/bin/pg: /sbin/loader: Fatal Error: this executable has unresolvable symbols
How to fix it? please help me.
5 REPLIES
Han Pilmeyer
Esteemed Contributor

Re: Error: Unresolved symbol in /usr/bin/pg: safe_open

safe_open was added in PK3, I believe, as one of the security fixes. It comes from libc.so (one of the 2 dynamic libraries used by pg).

You can verify that safe_open is in libc by using the "nm /usr/shlib/libc.so | grep safe_open" command. You should get two lines of output.

Looks like there is a descrepancy between pg and libc. Are you sure the patch kit installed without problems?
Chanatip Laongsiriwong
Occasional Advisor

Re: Error: Unresolved symbol in /usr/bin/pg: safe_open

I run "nm /usr/shlib/libc.so | grep safe_open". But not show anything. Some patch in patch kit can't install. Because have to uninstall CSP. Is this cause? If don't uninstall. How to fix? thank you.
Han Pilmeyer
Esteemed Contributor

Re: Error: Unresolved symbol in /usr/bin/pg: safe_open

Typically it would be good to have the complete patch kit installed.

Is there a reason why you still need the CSP? If you tell me what the CSP is, then I can verify in which patch kit it is included.

This could very well be the reason why the pg command fails in this way. Do you know which patches haven't installed?
Ann Majeske
Honored Contributor

Re: Error: Unresolved symbol in /usr/bin/pg: safe_open

A CSP for one patch kit shouldn't be used with the next patch kit, so you should de-install the CSPs and then re-install the new patch kit. Check the contents of the patch kit to see if it includes the CSPs. If not, you should open a case with HP to get a version of the CSPs compatible with the new patch kit.

I believe the removal of CSPs on patch kit installation has been automated for V5.1B, but not for the previous versions. I also believe the list of CSPs that are superceeded by a patch kit are also now listed in either the patch summary or the release notes for the most recent patch kits on V5.1B. For previous versions and patch kits you have to look at the description of each patch to see if it matches the description of the problem solved by the CSP, or contact HP for confirmation that the patch kit includes the fix for the CSP.

Ann
Chanatip Laongsiriwong
Occasional Advisor

Re: Error: Unresolved symbol in /usr/bin/pg: safe_open

These are patch that need to uninstall before
Patch C 00094.01
Patch C 00096.01
Patch C 00097.00
Patch C 00098.00
Patch C 000121.00
Patch C 00093.03

Can I uninstall them? Mostly about security.