Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Tru64 box . Network very Slow

S Bhat
Occasional Contributor

Problem with Tru64 box . Network very Slow



Hello All,

I am facing a problem in tru64 box . It is running slow after disk upgrade .

It seems problem is due to network Auto-Negotiate mode .



Consvar -l -v shows below outut .

char_set =
language = 0x32
tty_dev = 0
Failed to get scsiid
Failed to get scsifast
Failed to get com1_baud
Failed to get com1_modem
Failed to get com1_flow
Failed to get com1_misc
Failed to get com2_baud
Failed to get com2_modem
Failed to get com2_flow
Failed to get com2_misc
Failed to get password
Failed to get secure
Failed to get logfail


I am using le0 interface . Could anybody tell me the console variable for console for LE0 interface ? (for ee0 is eia0_mode , for tu0 is eia0_mode ) I do not know the variable for le0 interface .


Thanks & Regards
Shashi



consvar -g eXX0_mode ?
4 REPLIES
Ivan Ferreira
Honored Contributor

Re: Problem with Tru64 box . Network very Slow

It's very likely that that is your problem, but you can use the lan_config command to change the speed and duplex settings, for example:

lan_config -i le0 -s 100 -x 1 -a 0

You can check your current status whith the command:

hwmgr get attr -cat network | grep -E "name | speed | duplex"
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
S Bhat
Occasional Contributor

Re: Problem with Tru64 box . Network very Slow

Dear Ivan,

Thanks for quick responce . I am using Digital UNIX V4.0G . So I dont have hwmgr command .


For lan_config it is throwing following errors.

# lan_config -i le0 -s 100 -x 0 -a 1
unsupported: Invalid argument
# lan_config -i le0 -s 100 -a 1
unsupported: Invalid argument
# lan_config -i le0 -a 1
unsupported: Invalid argument



# ifconfig -a
le0: flags=c63
inet 192.168.100.60 netmask ffffff00 broadcast 192.168.100.255 ipmtu 1400
sl0: flags=10



Thanks & Regarsd,
Shashi
Ivan Ferreira
Honored Contributor

Re: Problem with Tru64 box . Network very Slow

I that case, you must set the speed from the console level. Once I tried to change the speed and duplex setting using consvar and the system crashed.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
KLT
Occasional Visitor

Re: Problem with Tru64 box . Network very Slow

From the manpage le(7), it looks like the le interface supports only 10Mbps speed. Also, there's no indication that it supports IEEE 802.3u autonegotiation. This is probably why you're getting those errors from lan_config. Using a non-autonegotiating adapter with an autonegotiating switch is problematic at the best of times. Try locking down the switch port to which the le is connected to 10Mpbs with autonegotiate disabled.

-thonuzo