Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Purging data on RZ28M disks in an Alpha 1000 server

Go to solution
Tom Wolf_3
Valued Contributor

Purging data on RZ28M disks in an Alpha 1000 server

Hello, let me start by saying I'm not very familiar with Tru64. With that said, we have an old Alpha 1000 server with two internal disks, rz2 and rz3. Both are RZ28M drives. I'm using an open source utility, scrub, to remove all data from these disks. I've successfully used this utility in the past to wipe disk drives on Tru64, AIX and HP-UX servers. It writes patterns on special files (i.e. raw disk devices) or regular files to reduce the possibility of someone retrieving the data. It's run from the command line via the following:

#scrub -r /dev/rrz2c

The -r flag results in disk being over written six times. When I run this command on /dev/rrz2c, I keep receiving the following error:

write: I/O error

I tried the following to zero out and re-create the disk label. I then restarted the scrub utility but got the same error.

#disklabel -z rz2
#disklabel -rw rz2

When I issue the disklabel command with just the disk name I get the output listed below. I don't see any obvious problems with the disk so I'm not certain why I keep encountering I/O errors. This is probably a long shot but I'm hoping someone familiar with this scrub utility and Tru64 may be able to provide some insight into solving this problem. Any help would be greatly appreciated.

Thank you.

Tom Wolf

# disklabel rz2
# /dev/rrz2a:
type: SCSI
disk: RZ28M
bytes/sector: 512
sectors/track: 99
tracks/cylinder: 16
sectors/cylinder: 1584
cylinders: 2595
sectors/unit: 4110480
rpm: 5411
interleave: 1
trackskew: 12
cylinderskew: 25
headswitch: 0 # milliseconds
track-to-track seek: 0 # milliseconds
drivedata: 0

8 partitions:
# size offset fstype [fsize bsize cpg] # NOTE: values not exact
a: 131072 0 unused 0 0 # (Cyl. 0 - 82*)
b: 401408 131072 unused 0 0 # (Cyl. 82*- 336*)
c: 4110480 0 unused 0 0 # (Cyl. 0 - 2594)
d: 1191936 532480 unused 0 0 # (Cyl. 336*- 1088*)
e: 1191936 1724416 unused 0 0 # (Cyl. 1088*- 1841*)
f: 1194128 2916352 unused 0 0 # (Cyl. 1841*- 2594)
g: 1787904 532480 unused 0 0 # (Cyl. 336*- 1464*)
h: 1790096 2320384 unused 0 0 # (Cyl. 1464*- 2594)
Hein van den Heuvel
Honored Contributor

Re: Purging data on RZ28M disks in an Alpha 1000 server

Well, it might be just that... and I/O error.

Tries re-seating already?
Tried popping everything on the bus except that drive (and a terminator :-) ?

How about doublechecking with the old standby 'dd'.

Try both read and write and see what happens. Maybe it give an error also.
If so, pop the drive, take it to a drill-press, and have at it! Good therapy!


dd of=/dev/rrz2c if=/dev/zero bs=1024k


dd if=/dev/rrz2c of=/dev/null bs=1024k