Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Terminal Settings (Again)

Paul Stanard
Regular Advisor

Terminal Settings (Again)

I installed starnet x-windows client. When I login as bwuser using the x-win and run a terminal i get ^H when I use the backspace key. Any idea how to remedy this before my users complain. Its very annoying
3 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: Terminal Settings (Again)

Hi,

try this:
stty erase "^?"

Michael
Hein van den Heuvel
Honored Contributor

Re: Terminal Settings (Again)


There is a mismatch between the stty settings and the terminal.
You can fix this in either place (but not both places :-).

For the unix fix check out:

check out 'man stty'

specifically look for thinkgs like ' + The string ^? sets the special character to .'
You may need: stty -erase ^h

In the terminal setup , look for some 'keyboard mapping' section. You can probably eitehr explicitly define what the 'backspace' key sends, or 'swap backspace and delete'.

You may aslo want to address this through 'terminfo' and friends: man terminfo

hth,
Hein.


Ralf Puchner
Honored Contributor

Re: Terminal Settings (Again)

you can remap the key via stty command as explained in your previous thread or setup your windows software to do the right job on the client side. But this depend on the implementation and possiblities of the client software.
Help() { FirstReadManual(urgently); Go_to_it;; }