Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Tru64 5.1B - Cannot install new version of the openssh

Rafael Mori
Advisor

Tru64 5.1B - Cannot install new version of the openssh

Hi experts,

I have Tru64 5.1B with PK6 with "SSH Secure Shell Tru64 UNIX 3.2.0". When I upgrade to a new version "OpenSSH 3.8.1p1" the installation abort and not generate errors:

STEP 1
# ./configure -with-zlib=/opt/TWWfsw/zlib11/include
checking for gcc... no
checking for cc... cc
... ---->>>>> complete lines, please, check log in attachment!
config.status: creating ssh_prng_cmds
config.status: creating config.h
config.status: config.h is unchanged

OpenSSH has been configured with the following options:
User binaries: /usr/local/bin
System binaries: /usr/local/sbin
Configuration files: /usr/local/etc
Askpass program: /usr/local/libexec/ssh-askpass
Manual pages: /usr/local/man/manX
PID file: /var/run
Privilege separation chroot path: /var/empty
sshd default user PATH: /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
Manpage format: man
PAM support: no
KerberosV support: no
Smartcard support: no
S/KEY support: no
TCP Wrappers support: no
MD5 password support: no
IP address in $DISPLAY hack: no
Translate v4 in v6 hack: no
BSD Auth support: no
Random number source: OpenSSL internal ONLY

Host: alphaev6-dec-osf5.1
Compiler: cc
Compiler flags: -g
Preprocessor flags: -I/opt/TWWfsw/zlib11/include
Linker flags: -L/opt/TWWfsw/zlib11/include
Libraries: -lcrypto -lrt -lz -lsecurity -ldb -lm -laud

STEP 2
# make
if test ! -z ""; then /usr/bin/perl ./fixprogs ssh_prng_cmds ; fi
(cd openbsd-compat && make)

STEP 3
# make test
Make: Don't know how to make test. Stop.

STEP 4
# make install
if test ! -z ""; then /usr/bin/perl ./fixprogs ssh_prng_cmds ; fi
(cd openbsd-compat && make)
(cd scard && make DESTDIR= install)
../mkinstalldirs /usr/local/share
.././install-sh -c -m 0644 ./Ssh.bin /usr/local/share/Ssh.bin
./mkinstalldirs /usr/local/bin
./mkinstalldirs /usr/local/sbin
./mkinstalldirs /usr/local/man
./mkinstalldirs /usr/local/share
./mkinstalldirs /usr/local/man/man1
./mkinstalldirs /usr/local/man/man5
./mkinstalldirs /usr/local/man/man8
./mkinstalldirs /usr/local/libexec
(umask 022 ; ./mkinstalldirs /var/empty)
./install-sh -c -m 0755 -s ssh /usr/local/bin/ssh
./install-sh -c -m 0755 -s scp /usr/local/bin/scp
./install-sh -c -m 0755 -s ssh-add /usr/local/bin/ssh-add
./install-sh -c -m 0755 -s ssh-agent /usr/local/bin/ssh-agent
./install-sh -c -m 0755 -s ssh-keygen /usr/local/bin/ssh-keygen
./install-sh -c -m 0755 -s ssh-keyscan /usr/local/bin/ssh-keyscan
./install-sh -c -m 0755 -s sshd /usr/local/sbin/sshd
if test ! -z "" ; then ./install-sh -c -m 0755 -s ssh-rand-helper /usr/local/libexec/ssh-rand-helper ; fi
./install-sh -c -m 4711 -s ssh-keysign /usr/local/libexec/ssh-keysign
./install-sh -c -m 0755 -s sftp /usr/local/bin/sftp
./install-sh -c -m 0755 -s sftp-server /usr/local/libexec/sftp-server
./install-sh -c -m 644 ssh.1.out /usr/local/man/man1/ssh.1
./install-sh -c -m 644 scp.1.out /usr/local/man/man1/scp.1
./install-sh -c -m 644 ssh-add.1.out /usr/local/man/man1/ssh-add.1
./install-sh -c -m 644 ssh-agent.1.out /usr/local/man/man1/ssh-agent.1
./install-sh -c -m 644 ssh-keygen.1.out /usr/local/man/man1/ssh-keygen.1
./install-sh -c -m 644 ssh-keyscan.1.out /usr/local/man/man1/ssh-keyscan.1
./install-sh -c -m 644 sshd_config.5.out /usr/local/man/man5/sshd_config.5
./install-sh -c -m 644 ssh_config.5.out /usr/local/man/man5/ssh_config.5
./install-sh -c -m 644 sshd.8.out /usr/local/man/man8/sshd.8
if [ ! -z "" ]; then ./install-sh -c -m 644 ssh-rand-helper.8.out /usr/local/man/man8/ssh-rand-helper.8 ; fi
./install-sh -c -m 644 sftp.1.out /usr/local/man/man1/sftp.1
./install-sh -c -m 644 sftp-server.8.out /usr/local/man/man8/sftp-server.8
./install-sh -c -m 644 ssh-keysign.8.out /usr/local/man/man8/ssh-keysign.8
rm -f /usr/local/bin/slogin
ln -s ./ssh /usr/local/bin/slogin
rm -f /usr/local/man/man1/slogin.1
ln -s ./ssh.1 /usr/local/man/man1/slogin.1
if [ ! -d /usr/local/etc ]; then ./mkinstalldirs /usr/local/etc; fi
/usr/local/etc/ssh_config already exists, install will not overwrite
/usr/local/etc/sshd_config already exists, install will not overwrite
/usr/local/etc/moduli already exists, install will not overwrite
/usr/local/etc/ssh_host_key already exists, skipping.
/usr/local/etc/ssh_host_dsa_key already exists, skipping.
/usr/local/etc/ssh_host_rsa_key already exists, skipping.
/usr/local/sbin/sshd -t -f /usr/local/etc/sshd_config
9 REPLIES
Steven Schweda
Honored Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

> I have Tru64 5.1B [...]

So why ask in an HP-UX forum?

> [...] When I upgrade to a new version
> "OpenSSH 3.8.1p1" [...]

This must be some new meaning of "new".
OpenSSH 3.8.1p1 seems to date from April
2004. The current version seems to be 5.1p1.

http://www.openssh.com/portable.html
ftp://mirror.mcs.anl.gov/pub/openssh/portable/

> [...] the installation abort [...]

It does? What, exactly, is your complaint?

> # make test
> Make: Don't know how to make test. Stop.

Perhaps, "make tests"?

I just tried to build 5.1p1 on my system,
with some success:

urtx# CC=cc ./configure --with-zlib=/usr/local

"make tests" died early:

[...]
run test connect.sh ...
Privilege separation user sshd does not exist
FATAL: sshd_proxy broken
*** Exit 1
Stop.
*** Exit 1
Stop.

But it wasn't a complete failure:

urtx# /usr/local/bin/ssh -V
OpenSSH_5.1p1, OpenSSL 0.9.7d 17 Mar 2004

urtx# /usr/local/bin/ssh -l sms alp-l "tcpip show version"


HP TCP/IP Services for OpenVMS Alpha Version V5.4 - ECO 7
on a COMPAQ Professional Workstation XP1000 running OpenVMS V7.3-2

urtx# sizer -v
HP Tru64 UNIX V5.1B (Rev. 2650); Mon Feb 19 11:57:07 CST 2007
Rafael Mori
Advisor

Re: Tru64 5.1B - Cannot install new version of the openssh

Sorry, the old version is the same installed on my client (company).

The problem amateur ehehe... "make test". I execute 'make tests' and one error ocurred in SFTP tests, but after download of the last version "openssh-5.1p1.tar.gz" the problem in 'make tests' solved, but the same problem ocurred in "make install":

STEP 1 -> ./configure -with-zlib=/opt/TWWfsw/zlib11/include --> No errors

STEP 2 -> make --> No errors

STEP 3 -> make test --> No errors
...
run test localcommand.sh ...
test localcommand: proto 1 localcommand
test localcommand: proto 2 localcommand
ok localcommand
run test forcecommand.sh ...
ok forced command
all tests passed

STEP 4 -> make install
...
ln -s ./ssh /usr/local/bin/slogin
rm -f /usr/local/share/man/man1/slogin.1
ln -s ./ssh.1 /usr/local/share/man/man1/slogin.1
if [ ! -d /usr/local/etc ]; then ./mkinstalldirs /usr/local/etc; fi
/usr/local/etc/ssh_config already exists, install will not overwrite
/usr/local/etc/sshd_config already exists, install will not overwrite
/usr/local/etc/moduli already exists, install will not overwrite
/usr/local/etc/ssh_host_key already exists, skipping.
/usr/local/etc/ssh_host_dsa_key already exists, skipping.
/usr/local/etc/ssh_host_rsa_key already exists, skipping.
/usr/local/sbin/sshd -t -f /usr/local/etc/sshd_config

# ssh -V
ssh: SSH Secure Shell Tru64 UNIX 3.2.0

--> The 'make install' stop in line '/usr/local/sbin/sshd -t -f /usr/local/etc/sshd_config' and cannot generate errors...
--> Complete log in attachment...
Steven Schweda
Honored Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

> [...] the same problem ocurred in "make
> install":

What problem? "will not overwrite"? That's
a problem? The OpenSSH installation
procedure does not want to damage your
existing configuration files (which you may
have edited). If you don't want to see those
complaints, then remove your old
configuration files before installing the new
product.

> # ssh -V
> ssh: SSH Secure Shell Tru64 UNIX 3.2.0

That's not OpenSSH.

type ssh
/usr/local/bin/ssh -V
John Manger
Valued Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

As Steven said above, Tru64's SSH is NOT OpenSSH.

It is quite possible to have OpenSSH and Tru64 SSH 'co-exist' but you really should not try to overwrite the Tru64 version. Tru64's SSH is pretty good and doesn't usuall need replacing. And provided you install the current PK+ERPs, it will have the most up to date fixes etc.

So, What funtionality do you require that the native version does not supply ? (ssh V1 perhaps ? or a particular 'target' that doesnt like some aspect of Tru64's SSH ?)
Nobody can serve both God and Money
Rafael Mori
Advisor

Re: Tru64 5.1B - Cannot install new version of the openssh

Hmm... I think that the old version "HP SSH" is uptaded to a new version of OpenSSH, sorry!

# /usr/local/bin/ssh -V
OpenSSH_5.1p1, OpenSSL 0.9.7d 17 Mar 2004
It´s great...

Now, how to set default OpenSSH_5.1p1 and disable the HP SSH?
Rafael Mori
Advisor

Re: Tru64 5.1B - Cannot install new version of the openssh

Any idea?
Steven Schweda
Honored Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

> Now, how to set default OpenSSH_5.1p1

First week on the job using UNIX? Set your
PATH environment variable so that
"/usr/local/bin" comes before wherever the
other ssh program is. Or define an alias, or
whatever your shell (whichever shell you're
using) provides. "man your_shell".

> and disable the HP SSH?

Disable? Why? If you don't want to use it,
then don't use it. Why damage it? How much
trouble are you trying to create?

Or are you interested in replacing the sshd
_server_ , instead of the ssh _client_?

What, exactly, are you trying to do?
Robert Walker_8
Valued Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

Gday,

We run openssh/ssl as opposed to Tru64 - which has often been out of date compared with that provided by openssh.org.

We move all Tru64 SSH components a side - renaming as /sbin/init.d/sshd to sshd.orig or something then pop our openssh version.

This was more relevant and carried on from Tru64 V5.1a which didnt originally arrive with SSH.

I shall post my problem regarding openssh as a separate case as this would appear to be a different issue.

Robert.
Ann Majeske
Honored Contributor

Re: Tru64 5.1B - Cannot install new version of the openssh

SSH is supplied as part of the Tru64 OS for V5.1B and is upgraded when installing a new patchkit. Note that the version number (V3.2.0) does NOT change, but SSH is upgraded to the latest Tru64 version by the patchkit. The OS uses its own SSH for various things, e.g. cluster communication. If you try to delete or move aside the SSH supplied with the OS it can cause many problems including cluster communication problems and failures when you try to install a new patchkit. I strongly recommend that if you want to use OpenSSH you should install it on an alternate path and not mess with the SSH included with the OS.