Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

Tru64 UNIX Booting Problem (2)

Luthfi
Occasional Advisor

Tru64 UNIX Booting Problem (2)

I'm sorry, i didn't realize that i mark my last thread (Tru64 UNIX Booting Problem) with "magical answer". In fact, my problem has not yet completely solved.
I still have question for my problem on Alphaserver DS25 that the error message when booting shows there is damaged disk.

I tried use /sbin/advfs/verify but i don't know the disk's domainName.
I read again installation guide -advance topic and execute several command :

# hwmgr -view device
HWID: Device Name Mfg Model Location
------------------------------------------------------------------------------
4: (unknown)
5: (unknown)
6: (unknown)
62: /dev/disk/cdrom0c HL-DT-ST RW/DVD GCC-4482B bus-0-targ-0-lun-0
63: /dev/disk/dsk0c COMPAQ BF03688284 bus-2-targ-0-lun-0
64: /dev/disk/dsk1c COMPAQ BD07288277 bus-2-targ-1-lun-0
65: /dev/disk/dsk2c COMPAQ BD07288277 bus-2-targ-2-lun-0
66: /dev/disk/dsk3c COMPAQ BD07288277 bus-2-targ-3-lun-0
67: /dev/disk/cdrom1c SONY CD-RW CRX230ED bus-5-targ-1-lun-0
68: (unknown)
69: (unknown)
70: (unknown) SONY SDX-700V bus-4-targ-5-lun-0
71: (unknown) SONY SDX-700V bus-4-targ-6-lun-0

i tried to mount all 4 disk in list above but it failed:

for dsk0c
# mount root_domain#root /var/mnt
Error: partition(s) which overlap /dev/disk/dsk0c are marked in use
in the disklabel. Use "disklabel -e" to fix the disklabel if it
is improperly labeled.

for dsk1c
# mount root_domain#root /var/mnt
root_domain#root on /var/mnt: No such domain, fileset or mount directory

for dsk2c
# mount root_domain#root /var/mnt
root_domain#root on /var/mnt: No such domain, fileset or mount directory

for dsk3c
# mount root_domain#root /var/mnt
Error: partition(s) which overlap /dev/disk/dsk3c are marked in use
in the disklabel. Use "disklabel -e" to fix the disklabel if it
is improperly labeled.

is the above message normal?
from error message when booting with disk, the damaged disk is BF03688284 = dsk0c.
but mounting dsk0a result in AdvFS. When i check file inside, some of my data is not there. i don't know whether it is lost or it is in other disk.

which disk i should fix or replace? dsk0a or dsk0c? if i have to fix it what command i should use to check and mark bad sector in disk. and how to know which physical device (disk) correspond to dsk0a and dsk0c?
Thank you.

Luthfi
3 REPLIES
Ivan Ferreira
Honored Contributor

Re: Tru64 UNIX Booting Problem (2)



First, a little of concepts:

In tru64 dskN is the disk device special file. The disk can be partitioned, partitions can be a,b,c,g,h. For example:

dsk0a
dsk0c

Are the same disk. So the answer for your last question is dsk0a and dsk0c are the same physical disk.

Before going in more details, can you boot in single user?

boot -fl s

If you can't, then continue reading...

When you boot from the cd, domains are not created. If you want to mount your disks you must manually create the domains. But, to create the domains you must know what partitions where used in your disks before.

I will describe some examples. Normally, dsk0 will be your boot disk and holds the operating system. During OS installation, the disk is normally partitioned in a (root), b (swap), g (usr), h (var?). To identify which partitions are in use you can execute disklabel, for example:

disklabel -r dsk0

You will see which partitions are marked with AdfFS file system. The c partition uses the whole disk and if you see AdvFS in the c partition, then you can't have other partitions on the same disk.

So, continuing with dsk0, you identified which partitions where used, then you have to create the domains:

mkfdmns /etc/fdmns/fs1
ln -s /dev/disk/dsk0a /etc/fdmns/fs1/dsk0a
mkfdmns /etc/fdmns/fs2
ln -s /dev/disk/dsk0a /etc/fdmns/fs1/dsk0g
mkfdmns /etc/fdmns/fs3
ln -s /dev/disk/dsk0a /etc/fdmns/fs1/dsk0h

Now you can do several things:

- Display filesets:

showfsets fs1
showfsets fs2
showfsets fs3

- Mount filesets to try to recover data:

mount fs1#root /mnt/root/
mount fs1#usr /mnt/usr
mount fs1#var /mnt/var

- Run verify to the domains fs1, fs2 and fs3

If you had only the c partition, then the procedure is similar

mkfdmns /etc/fdmns/fs4
ln -s /dev/disk/dsk1c /etc/fdmns/fs1/dsk1c
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Luthfi
Occasional Advisor

Re: Tru64 UNIX Booting Problem (2)

Ivan, thank you for your suggestion.
I'm sorry i was out of office for a week, so i didn't continue work on this problem. Now i'm back.
I have tried following your instruction.
I found that my 1st disk has 5 partition, ie. a (root, advfs), b (swap), f (advfs), g(advfs) and h (advfs).
I made domain for each of partition then displaying fileset.
I found error when displaying fileset for partition f. It shows "MEDIUM ERROR ..." the same error like when trying booting from disk.
I tried mounting each of partition, but it always failed. I didn't know what partition it is. I mean i don't know whether it is usr partition or var partition or others. How to check it?

I have system backup on tape. I don't know how to restore for each of partition. I have tried execute vrestore -x on root (device for tape is tape0). it seem succeed. but how if i want to restore for other partion, can i use the same command or there is option i have to add?

Thank you
Luthfi
Occasional Advisor

Re: Tru64 UNIX Booting Problem (2)

Thanks Ivan and HP Forum,

It works now. After founding that f partition is damage, i get a suggestion from our vendor how to restore f partition from tape. I boot in single user then create usr domain that f partition is for usr and var data.
Now i can work again with my server.
Thanks.