Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

Aco Blazeski
Regular Advisor

URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

Hi,

I have ES45 single cluster with Tru64 5.1A + TruCluster + PK4 with FCA 2354 HBA adapters with 2.11 driver.
I need to upgrade driver from 2.11 to 2.14.
First I've installed PK6 and it went smooth.
Then I've installed patch kit T64KIT0022092-V51AB24-E-20040412.tar which should upgrade FCA drv from 2.11 to 2.14. But drv version stays the same (2.11).
I have installed this patch kit successfully on a few non-cluster 5.1A, but have no that luck with TruCluster.

Does someone have some idea, suggesstion ???
Your time will be appreciated.

regards,
4 REPLIES
Vladimir Fabecic
Honored Contributor

Re: URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

Did the patch normaly rebuild the kernel?
Was the rebuilt kernel installed?
Did you try to build kernel manualy with doconfig?
In vino veritas, in VMS cluster
Aco Blazeski
Regular Advisor

Re: URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

Hi Vladimir,

I;ve performed no-roll patching.
yes, the patching did kernel rebuild, and the new kernel is installed. I did not manual doconfig. Here's the tail of session.log:

t# tail -50 session.log | more
Waiting for all cluster members to complete event operation...


=== Installing "Tru64 UNIX V5.1A" Patches:

1 subsets will be installed.

Loading subset 1 of 1 ...

Patch: AT_G08565: Fix for premature connection termination
Copying from /var/tmp/KIT214/patch_kit/Tru64_UNIX_V5.1A/kit (disk)
Verifying

1 of 1 subsets installed successfully.


*** Starting protofile merges for "Tru64 UNIX V5.1A Patch Distribution" (T64KIT0022130-V51AB24-E-20040414OSF520,14-Apr-2004
:18:41:11) ***


Configuring "Patch: AT_G08565: Fix for premature connection termination" (OSFPATC0147602520) on member0


*** Finished protofile merges for "Tru64 UNIX V5.1A Patch Distribution" (T64KIT0022130-V51AB24-E-20040414OSF520,14-Apr-2004
:18:41:11) ***


Configuring "Patch: AT_G08565: Fix for premature connection termination" (OSFPATC0147602520) on member1

*** KERNEL CONFIGURATION AND BUILD PROCEDURE ***

Saving /sys/conf/SALOMON as /sys/conf/SALOMON.bck


*** PERFORMING KERNEL BUILD ***

A log file listing special device files is located in /dev/MAKEDEV.log
Working....Mon Apr 10 12:07:53 CEST 2006

The new kernel is /sys/SALOMON/vmunix
Waiting for all cluster members to complete event operation...
Waiting for all cluster members to complete event operation...
Waiting for other cluster members to reboot...

Existing kernel copied to cluster/members/{memb}/boot_partition/vmunix.PrePatch.

New Kernel (/sys/SALOMON/vmunix) copied to
cluster/members/{memb}/boot_partition/vmunix.

*** successfully installed 1 patches; failed to install 0 patches ***

* A system reboot of the patched system is required for the successfully installed patches.


Vladimir Fabecic
Honored Contributor

Re: URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

Very strange!
Looks like patching was OK.
Anyway, check creation date of running vmunix kernel.
Also try to manualy build kernel with doconfig.
In vino veritas, in VMS cluster
Aco Blazeski
Regular Advisor

Re: URGENT: upgrade of FC HBA drv from 2.11 to 2.14 wont work on Clusters

I just can;t belive it ! I've installed wrong patch -> just kill me...

Sorry guys