Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

Upgrade from 4.0D to 5.0

Occasional Visitor

Upgrade from 4.0D to 5.0


I'm in the middle of upgrading from 4.0D to 5.0 and have hit a snag. The installation seemed to go ok, then the server automatically rebooted, then the system was configured and the kernel was automatically rebuilt and the system was rebooted again. This time, when the system was booting, it errored when trying to mount the local filesystems. I got the following error:

Checking device naming:
Checking local filesystems
Mounting / (root)
Cannot find boot filesystem mount point
mountroot: Please correct the mount problem and reboot

I tried running bcheckrc and got the same error message. The following is my /etc/fstab file:

root_domain#root / advfs rw 0 0
/proc /proc procfs rw 0 0
usr_domain#usr /usr advfs rw 0 0

The root domain is currently mounted and I could successfully mount the usr domain as well.

Any ideas on how I can fix this?
Ivan Ferreira
Honored Contributor

Re: Upgrade from 4.0D to 5.0

The error message is extrange:

Cannot find boot filesystem mount point

The boot filesystem mount point should be /. If cannot find the /, then there should be a logical problem in the file system. The verify should be runned before the upgrade installation.

You should run the /sbin/advfs/verify command to your filesystems.

From "man 8 verify":

If you want to run the verify command on the root file domain, choose the -a option to view diagnostic warnings, or boot from another disk or installation CD and use the -f or -d option as shown in the Example section.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Michael Schulte zur Sur
Honored Contributor

Re: Upgrade from 4.0D to 5.0


did you know the exact point where the problem occurred?