Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

desta start fails

Michael Schulte zur Sur
Honored Contributor

desta start fails

Hi all,

I am getting
desta: Cannot map text.
when trying to start webes. Reinstallation does not help. Runs on 5.1A pk6 on two node cluster.

Please help, thanks,

Venkatesh BL
Honored Contributor

Re: desta start fails

Are you seeing this problem after some configuration change or system panic?...looks like the VM is not able to map the text segment of the file.

Re: desta start fails

Hello Michael,
today I had a similar case with the exact same errormessage. Even though your case is a bit old now I thought you might be interrested what solved my issue...

Just when I was really deperate and about to write a procedure on howto reinstall all WEBES and wipe all registration-data off,
I found something in the sys_check....

swapon -s

Total swap allocation:
Allocated space: 0 pages (0.00KB)
In-use space: 0 pages ( 0%)
Available space: 0 pages ( 0%)

Eh! whatsthis....*check sysconfigtab*....look...no vm: swapdevice definition on both members.
Allright. THATS it!

During "desta start" that script is trying to perfom a "head -n" onto a file...and this needs some vm to work with the data
but cannot get it due to the fact that there is no vm available...thus it return "cannot map text", thus desta doesnt start.

Now we added the correct entry in sysconfigtab (it was missing on both cluster members) for the swapdefault
did "swapon -a".....tried starting desta..and tataaaaa...it works!

Ok to close the case.

regads Uwe
Michael Schulte zur Sur
Honored Contributor

Re: desta start fails

Problem is no longer relevant because I left the company.
Ivan Ferreira
Honored Contributor

Re: desta start fails

What a coincidence. I'm just having the problem and the problem was that the swap device disk was not detected after a recent hardware change.

Thanks Uwe
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?