Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

domain panic

Super Advisor

domain panic


We have a TRU64 system with "Digital UNIX V4.0F (Rev. 1229)"

We have came across a domain panic on one of the data domain in our system.

Mar 2 16:16:23 delta vmunix: AdvFS Domain Panic; Domain data_domain Id 0x3f3e069d.00092a23
Mar 2 16:16:23 delta vmunix: An AdvFS domain panic has occurred due to either a metadata write error or an internal inconsistency. This domain is being ren
dered inaccessible.
Mar 2 16:16:23 delta vmunix: Please refer to guidelines in AdvFS Guide to File System Administration regarding what steps to take to recover this domain.

All the disks are accessible via disklabel.
But can not mount the disks. Gets a I/O error.

Kindly suggest how I should try filesystem check on this?
Unfortunately no backup data exists for this domain.

Super Advisor

Re: domain panic

I tried verify on the data_domain,

delta# ./verify data_domain
verify: can't get set info for domain 'data_domain'
verify: error = E_VD_DMNATTR_DIFF (-1079)

+++ Domain verification +++

main: unable to get info for domain 'data_domain'
error: -1079, E_VD_DMNATTR_DIFF (-1079)

What does it mean?
Super Advisor

Re: domain panic

The man page of advfs_err shows :

Some of the disks listed in fdmns directory for the file domain do not
belong to the file domain. The fdmns directory entry for this file
domain is invalid.

We have recreated the symlinks inside domain as there was a scsi id change after we connected the external disk array to different scsi port in the same host.

Does that affect this behaviour?
Pieter 't Hart
Honored Contributor

Re: domain panic

I don't think so,

On the disk there is "metadata" present that describe to what domains the disk belongs (or previously was part of)

It may simply mean the new domain name does not match the old domain-name.
Or I think when recreating the links, you cross linked disks from different old domains into the new domain.

Instead of manually recreating the links you may try to "recover" te domains using advscan

man advscan "You can run the advscan command to automatically rebuild all or part of
your /etc/fdmns directory "
Super Advisor

Re: domain panic

We brought down the system and did fixfdmn and it took lot of time to recover.
But after that when we connect the disk array to different host, , the domain was coming inactive.
Hence tried mounting it and then could see our data finally.

Thanx for your help.