Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

lprsetup remote printer Xerox DC 220

Melinda Myers
Occasional Visitor

lprsetup remote printer Xerox DC 220

I used lprsetup for this printer that is on a remote server. The /etc/printcap entry is as follows:

lp3|3|QNAME:\
:lf=/usr/adm/lp3err:\
:lp=:\
:rm=QNAME:\
:rp=text:\
:sd=/usr/spool/lpd3:

Where QNAME is the name of the queue on the remote server. I have added an /etc/hosts entry for QNAME for the correct IP. The printer is on and I have verified that I have the correct IP. When a printjob is sent to the printer it just "hangs" in the queue.
The lpstat -a reflects the following:

QNAME:
printer is on remote host QNAME with name text
queuing is enabled
printing is enabled
1 entry in spool area
Tue Dec 30 14:56:34 2003: sending to QNAME

Another SA tells me that this has been a problem once in the past with Xerox printers, and she believes that it had something to do with the "rp" entry.

Anyone have any ideas?

Thanks.
3 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: lprsetup remote printer Xerox DC 220

Hi,

it certainly looks strange to me, if you use the same name for the host and queue. What kind of print server are you using? I myself prefer the tcpip protocol against the lpd protocol. Can you ping the printer/print server? Have you tried to send a text with ftp?

greetings,

Michael
Ralf Puchner
Honored Contributor

Re: lprsetup remote printer Xerox DC 220

First of all, HP does not support XEROX printers directly. So please find a compatible printer on the supported list and configure it identically.

Depending on your OS version you have different approaches:

- lpd, telnet printing
- local connection
- terminal server printing

be sure the xerox printer (e.g. printer card) supports the selected mode. If so have a look into the documentation and get portnumber or queuename for proper printing. Upper-/lowercase is important!

Use lprsetup to configure the printer. In newer versions of Tru64 there are pcf filters included.

A sample printcap entry is:

lp|lp0:\
:if=/usr/lbin/pcfof +Cln15.pcf:\
:lf=/usr/adm/lp0err:\
:mx#0:\
:lp=@printerhostname/socket_3001:\
:of=/usr/lbin/pcfof +Cln15.pcf:\
:pl#66:\
:pw#80:\
:sd=/usr/spool/lp0:\
:xf=/usr/lbin/xf:

pcfof is a default print filter and +C specifies the different printer (here ln15) related configurations. see /usr/lbin/pcf for additional printers and definitions. printerhostname is the hostname defined in /etc/hosts and socket_3001 is the name of the port defined within /etc/services.

The pcf filters does only work for PCL compatible printers. If using postscript printers, change if/of entry to a normal postscript filter!
Help() { FirstReadManual(urgently); Go_to_it;; }
Gary Hansford
Frequent Advisor

Re: lprsetup remote printer Xerox DC 220

I use Document Centre 220 ST's here, this is what I've done.

Printcap:

3|lp3|qname:\
:lf=/usr/adm/lp3.err:\
:lp=:\
:rm=qname:\
:rp=lp:\
:sd=/usr/spool/lp3:\
:sh:

I then use the following command to perform the prints (due to lpd daemon not doing it within the Document Centre).

cat ${FILE} | \
/usr/lbin/pcfof +Chplj4mplus_a4.pcf \
${xerox_opts} | \
lpr ${lpropts}

where:-

${FILE} = filename

${xerox_opt} = Print Options (man pcfof)

e.g. -Olandscape

${lpropts} = -#copies -Pprinter

Only what the LPD daemon of the DC supports

What is happening is the pcfof converts your file into a temporary PCF document which is then transfered to the LPD daemon on the DC220. The DC220 LPD daemon doesn't understand many of the layout commands but does interact nicely with LPR from Tru64.

Works lovely on 4.0f and 5.1 - no probs.

If there's a better solution out there - would be interested...

Hope this helps

Gary