Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
Showing results for 
Search instead for 
Did you mean: 

migrate system from gs160 to ds20

Go to solution
Telia BackOffice
Valued Contributor

migrate system from gs160 to ds20

Hi Tru64 experts

We have a trucluster consisting of 2xGS160. It used to be used for a lot of stuff. Now it is basically just running a single java application. We can not move away from tru64, but due to increased support costs, managers have cut support of one of the GS160's and want us unix admins to migrate the setup to a couple of DS20e's. And recently one of the GS160's blew up and the company is pushing for the migration.

Politics aside:

I have tried to setup a DS20e, taking all the 6 SCSI disks from the GS160 and put them into disk cages that will fit into the DS20e. I eventually got something to boot (finding the right boot file and such), but it bails out with cpu errors and stuff like that. It talks about qbb7, so I think its a configuration problem. Could you help me with how to migrate from a hardpartition in a GS160 to a single DS20e, just by moving the disk and fixing the config.

I'm a skilled unix admin, but tru64 newbie :-)

Steven Schweda
Honored Contributor

Re: migrate system from gs160 to ds20

I know nothing, but "Machine Check SYSTEM
Fatal Abort" sounds to me like more than "a
configuration problem". What do you know
about the status of the DS20e before you got
hold of it?

Before I started plugging in disks from some
other system, I'd try to see if the thing
worked a little. Pass POST, boot from a
CD-ROM, those sorts of things.
Rob Leadbeater
Honored Contributor

Re: migrate system from gs160 to ds20


I suspect that the main problem here is that you're trying to boot off a kernel designed for the GS160.

The main evidence for this is that the error output mentions CPUs 2 and 3, and the the DS20e only has two CPUs.

As a start, I'd try booting into single user, using the generic kernel, and see whether that allows you to get any further.

P00>> b -flags s -fi genvmunix

You'll probably need to build a new kernel using doconfig.

Hope this helps,


Telia BackOffice
Valued Contributor

Re: migrate system from gs160 to ds20

Hi Rob

Yeah, I figured that out myself. I am wondering on how to proceed. I have a disk that will allow the ds20 to boot into Tru64 5.1 without any errors. I am trying to migrate a 4.0 setup. Is the ds20 config from 5.1 usable as a starting point to build the new kernel? What drivers do I need and so forth. Or should I just see what happends with a doconfig when booting the generic 4.0 kernel?

I am also planning to take the HBAs from the GS160 and put them into the DS20 so that the storage zoning will remain fixed. Its an old setup belonging to a company which was bought by a company which my company bought! So the lesser changes, the fewer problems we will run into....

Rob Leadbeater
Honored Contributor

Re: migrate system from gs160 to ds20

Hi Thomas,

No. You need to be booting up off the version 4.0 boot disk. The way in which hardware is handled between v4 and v5 is vastly different.

You'll have to determine from the GS160 which is the original boot disk. The output of "show boot*" and "show dev" from the SRM (P00>>>) will probably help here, although the names will probably change when the disks are in the DS20, due to different buses etc.

You might also want to check whatever SAN configuration you've got (or shared storage). The original boot disks are not necessarily on SCSI.


Telia BackOffice
Valued Contributor

Re: migrate system from gs160 to ds20

Hi, I got it to boot, and fixed the advfs domains. But I'm struggeling with the vold> sudo voldisk list


rz10c simple - - error

rz33a nopriv - - error

rz33b simple - - error

rz33g nopriv - - error

rz33h nopriv - - error

rz37c simple - - error

rz8a nopriv - - error

rz8b simple - - error

rz8g nopriv - - error

rz8h nopriv - - error

rzb128 sliced - - error

rzb129 sliced - - error

rzb136 sliced - - error

rzb137 sliced - - offline

rzc128 sliced - - error

rzc136 sliced - - error

rzd128 sliced - - offline

rzd136 sliced - - offline

rze128 sliced - - offline

rze129 sliced - - offline

rze136 sliced - - error

rze137 sliced - - offline

voldisk: Fetch of records from vold failed:

Record not in disk group

My root disk has changed name from rz8 to rz0. How do I migrate these changes?

Telia BackOffice
Valued Contributor

Re: migrate system from gs160 to ds20> sudo /sbin/lsmbstartup -b> sudo /sbin/lsmbstartup -n

starting LSM

lsm:vold: Error: enable failed: Error in disk group configuration copies

No valid disk found containing disk group; transactions are disabled.

LSM: Vold is not enabled for transactions

No volumes started