Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

rpmbuild binary for TRU64 V5.1B

John_685
Occasional Visitor

rpmbuild binary for TRU64 V5.1B

I was able to download an rpm binary that runs on TRU64 V5.1B, but I also need to be able to download the rpmbuild binary for V5.1B. If this exists, can someone tell me the site/URL to download it from.

I also tried downloading the src from www.rpm.org and compiling it on our TRU64 server with little luck (a lot of compiling errors). That't why I am asking for a binary of rpmbuild.
6 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: rpmbuild binary for TRU64 V5.1B

Hi John,

please give us more details as to the nature of the compiler errors. Post some examples!

thanks,

Michael
Norman_20
Advisor

Re: rpmbuild binary for TRU64 V5.1B

John_685
Occasional Visitor

Re: rpmbuild binary for TRU64 V5.1B

Norman,

Thanks for your response!
The URL you provided is very good, but I already been there (that's where I got the rpm binary from and the rpm-3.0.2 src. I found that it's easier to try to compile the rpm src from www.rpm.org instead of the HP version. First, because the rpm.org is newer (4.1), and second it delivers more files so less problems... e.g. the rpm-3.0.2 doesn't deliver the libgettext.h file. This causes an error when running ./configure.

Michael,
Thanks for your response...
The www.rpm.org rpm source (4.1) is giving me a problem when trying to link in the libpthread.a file when linking rpm. The archive is not installed on our TRU64 server but the /usr/shlib/libpthread.so is (I know the archive is on linux in /usr/lib). The gcc compiler doesn't seem to like linking in a shared library (unless you know a better syntax then what's provided in the Makefile). If the libpthread.a is available for TRU64 I would need an archive for both v4.0f and v5.1b (we have two versions that we are using that I wish to put rpmbuild on).

Also under the tools subdirectory the elf.h file is not on TRU64, only elf_abi.h and elf_mips.h. Are either of those a valid replacement? The include elf.h is listed in the striptofile.c and unstriptofile.c files under the tools subdirectory.
Ralf Puchner
Honored Contributor

Re: rpmbuild binary for TRU64 V5.1B

/lib/libpthread.a is part of the OSFBASE-Kit and was replaced several time by different patches! Please use the command line

# grep libpthread.a /usr/.smdb./*.inv

to check if the library is within any installed kit on your version. Use setld -l to verify if the kit is properly installed.
Help() { FirstReadManual(urgently); Go_to_it;; }
Norman_20
Advisor

Re: rpmbuild binary for TRU64 V5.1B

Ok, you need to use this files, and all works.
CXXREDIST632V10.tar
rpm3.0.2archive.tar
RPM-init.ksh
I don't remember, but i think you don't need to compaile that....
By
Norman
John_685
Occasional Visitor

Re: rpmbuild binary for TRU64 V5.1B

Ralf,
Thanks for responding to my request, yes... you're correct the V5.1B has the libpthread.a in the OSFBASE kit. But that's not true for V4.0f (another OS we support), so I can't resolve bulding on V4.0f.

Norman,
You're right! My problems are resolved for V5.1B with the URL you provided. I am using the rpm binary to build rpm's now (THANKS!!).

Still Pending...
Should I open a different question for obtaining the rpm/rpmbuild binary for TRU64 V4.0f? Or do you know where I can find that? Remember, that the libpthread.a is also missing on V4.0f and not part of the OSFBASE, so I am exepecting compiling problems on V4.0f.