Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

tar problem on tru64 5.1A

amer_3
Advisor

tar problem on tru64 5.1A

Hi

im trying to backup or read files on my tape useing tar but it keep gives me I/O error.
wheni tryed vdump it worked fine "write & read".

i have tryed my tape on another machine but the same, i have Es40 system, tru64 v5.1A.
can any one help me.
7 REPLIES
Johan Brusche
Honored Contributor

Re: tar problem on tru64 5.1A


Do you have this I/O-error when tarring from any filesystem ?
If not do you have files in a particular filesystem larger than 2 GB ?

If files larger than 2GB, did you try the "E"(Extended Headers) commandswitch on tar.

Rgds,
___ Johan.

_JB_
amer_3
Advisor

Re: tar problem on tru64 5.1A

hi

first in my old system it did not take large files. but now im trying small files like /etc/hosts.
i dont get any I/O error when moving from filesystem to filesystem.

my problem is with the tar.
thanks
Johan Brusche
Honored Contributor

Re: tar problem on tru64 5.1A


Let's start again...and provide some detail ..

whereis tar ; which tar ?

/sbin/tar or /usr/bin/tar ?

So "tar cvf /var/tmp/temp.tar /etc/hosts" works, but
"tar cvf /dev/tape/tape0 /etc/hosts" gives I/O-error

What is the syntax of the tar command that gives this I/O-error ?

What is the output of the command,
file /dev/ntape/tape0

etc....


_JB_
amer_3
Advisor

Re: tar problem on tru64 5.1A

hi

thanks alot for your replay, the problem has been solved, it seems there was some conflect on the system i have restarted the the cluser and tryed the command

tar -cvEf /dev/ntape/tape0 /backup/ora1

and it worked fine.
i just have a quastion the backup took alot of time, the size of the file is arround 9GB and it took arround 2 hours to finsh the tar, is there any problem.

thanks alot
Ivan Ferreira
Honored Contributor

Re: tar problem on tru64 5.1A

The backup time depends of the device type that you are using and the type of files that you are backing up. If you are backing up many small files, it will take a long time. Also, depends of the system load.

You can try differents block sizes to get the optimum performance. You should use vdump for backup.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
amer_3
Advisor

Re: tar problem on tru64 5.1A



thanks alot for all
amer_3
Advisor

Re: tar problem on tru64 5.1A

thanks