Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Tru64 Unix
cancel
Showing results for 
Search instead for 
Did you mean: 

the patch version

SOLVED
Go to solution
邹琪
Occasional Contributor

the patch version

hi guys,
How can i check the installed patch kit version on v5.0a unix

Thanks
8 REPLIES
Agnes Coat
Advisor

Re: the patch version

# /usr/sbin/dupatch -track -type kit

But be aware that :
>> When a patch kit is listed, it does not necessarily mean
>> all patches on that kit are installed on your system.

and that 5.0A is no longer supported.

Agnes
邹琪
Occasional Contributor

Re: the patch version

Hi Agnes,

Thanks!But the dupatch isn't supported on
5.0?,could you tell me a method.

I know this way:
#more /var/adm/patch/log/event.log | grep
-E 'KITNAME'


have any way else?
Agnes Coat
Advisor
Solution

Re: the patch version

The version Tru64 Unix V5.0A isn't supported, I don't understand when you say "dupatch isn't supported on 5.0"...

Your system is running in 5.0 or 5.0A ??

#more /var/adm/patch/log/event.log | grep -E 'KITNAME'
is good so what is the problem/question ?

Agnes
邹琪
Occasional Contributor

Re: the patch version

This is my output:
#sizer -v
Compaq Tru64 UNIX V5.1B (Rev. 2650); Mon Jun 2 10:52:54 CST 2003

#/usr/sbin/dupatch - track - type kit

ksh: /usr/sbin/dupatch: not found

So I thinked the dupatch not support on
5.0a or higher

thanks again!
Agnes Coat
Advisor

Re: the patch version

V5.1B is the latest Tru64 version , so it's really good!

If you have :
> ksh: /usr/sbin/dupatch: not found
it's probably that there is none patches installed on your system.

To be definitively sure :
# cd /usr/.smdb.
# ls -l OSFPAT* --> for Tru64 Unix patches
# ls -l TCRPAT* --> for TruCluster patches

If "not found", no patch kit installed on your system...

Agnes

PS : In V5.1B, the latest patch kit is PK3/BL24
Ralf Puchner
Honored Contributor

Re: the patch version

check /var/adm/patch/log for entries, if not found - no patch installed.
Help() { FirstReadManual(urgently); Go_to_it;; }
Agnes Coat
Advisor

Re: the patch version

If no patches, no directory /var/adm/patch

Re: the patch version

If /usr/sbin/dupatch doesn't exist, you haven't installed any patch kits onto your system.
I was right about the whales & dolphins