Operating System - VMware
cancel
Showing results for 
Search instead for 
Did you mean: 

Does VMM 3.7 support ESX4

Nicolai Rasmussen
Regular Advisor

Does VMM 3.7 support ESX4

I can't seem to get the VMM agent running on ESX4. It dies with the following error messages:

ERROR - Failed to get license key information
ERROR - ESX Server Standalone can not be managed by VMM
VML -2: VMM does not manage ESX Base license edition!
8 REPLIES
Nicolai Rasmussen
Regular Advisor

Re: Does VMM 3.7 support ESX4

I forgot to mention that I AM running a full licensed version of ESX4.
Niels Vejrup Pedersen
Respected Contributor

Re: Does VMM 3.7 support ESX4

Hi,

According to the QuickSpecs it is supported on ESX 4.

Which version of SIM are you using ? (You need to be on 5.3.1)

Regards
Nicolai Rasmussen
Regular Advisor

Re: Does VMM 3.7 support ESX4

I am on SIM 5.3.1, but so far I don't think SIM has anything to do with it, since the agent wont even run on the host.
These are btw. the installed hp rpms on my hosts:

vmware-esx-drivers-ata-pata-hpt3x2n-400.0.3-1.0.4.164009
vmware-esx-drivers-scsi-hpsa-400.3.6.14.24vmw-1.0.4.164009
hp-snmp-agents-8.2.5-50.vmware4x
hp-agents-config-8.2.5-24
hpilo-400.1.1.1.1VMW-00001
hpvmmagent-4.7.0.1069-esx
hp-health-8.2.5-50.vmware4x
hpsmh-3.0.1-73
hp-smh-templates-8.2.5-51


Adrian Clint
Honored Contributor

Re: Does VMM 3.7 support ESX4

When you say you are fully licensed do you mean you have an ESX enterprise license loaded?
Nicolai Rasmussen
Regular Advisor

Re: Does VMM 3.7 support ESX4

No, I have a "vSphere Advanced license".

I've got HP software support working on this issue, as I was instructed to upgrade from VMM 3.7 to 3.7.1 on the sim server, but now the installation prompts me for ORACLE db cridentials, and I'm NOT running an oracle db...
They've been ad it for about a month now, and I'm starting to lose my patience :S
Diogo_Conrado
Frequent Advisor

Re: Does VMM 3.7 support ESX4

Do you know where I can find the version 3.7.1 to download?

Thanks.
Nicolai Rasmussen
Regular Advisor

Re: Does VMM 3.7 support ESX4

As far as I can understand 3.7.1 isn't officially available yet. Release should be November 2009 - which is now I guess.

Anyway, I got 3.7 running by adding dbType=MSSQL in sims globalsettings.props file (sim-install-dir/config/globalsettings.props).

I installed hpvmmagent-4.8.0.1047-esx on the ESX servers, and it appears to run just fine now :)
Nicolai Rasmussen
Regular Advisor

Re: Does VMM 3.7 support ESX4

3.7 is required for ESX 4. The install/upgrade problems from 3.6 to 3.7 was solved by adding dbType=MSSQL to the globalsettings.props file.