Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - VMware
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

SOLVED
Go to solution
pinkerton
Advisor

Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Hi,

now that 4.1 is out I am considering to test the upgrade from ESXi 4.0 to 4.1. The original installation was performed using the HP version of ESXi 4.0 that already contained the HP CIM providers.

Is there already a schedule when the CIM providers for 4.1 are going to be released?

Thanks
14 REPLIES
Jan Soska
Honored Contributor
Solution

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

hello,
it was released at ESXi4.1 release day - 12th July 2010.
Check drivers and downloads for your server, then click ESXi4.1, there you can find "HP ESXi Offline Bundle for VMware ESXi 4.1"

for example of you bl685c it is here: http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=3644728&prodNameId=3644729&swEnvOID=4091&swLang=8&mode=2&taskId=135&swItem=MTX-b98795300e7947d88f19ab56d6 and should work with all hp supported servers.

Jan
Jan Soska
Honored Contributor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

pinkerton
Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Great, thank you!
Jan Soska
Honored Contributor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Hi,
just to make sure - did you apply HP addons and everythink works like intended?

Jan
mike carpendale
Occasional Visitor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Hi Jan

Are your links applicable to BL460c G6 servers running ESXi 4.1 as well?

Thanks in advance
Mike
Jan Soska
Honored Contributor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Yes,
it should work.

Jan
Uwe Zessin
Honored Contributor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

The support link from the BL460C G6 blade points to the same item:
MTX-b98795300e7947d88f19ab56d6
.
Wichers
Occasional Visitor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

It would be "nice" if HP provided the CIM Provider package as a VUM (4.1)package, just like they did for the NMI drivers!!

Or, as an alternative, provide a VUM 4.1 Upgrade package for HP's ESXi 4.1 (with CIM and NMI).

Now the scenario is:
- Upgrade vCenter and VUM to 4.1
- Import the VMware ESXi 4.1 upgrade package in VUM.
- Import the HP NMI driver for ESXi in VUM
- Upgrade your ESXi Server(s) with VUM
- Install the NMI drivers with VUM
...
- Now, From the VMware CLI run the vihostupdate utility to insert/upgrade the CIM providers.

This last step is really a bugger...
mike carpendale
Occasional Visitor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

YES! that would be fantastic!

I've held off install the CIM package because its such a pain.

Since I've got a SIM Server with Insight Control Virtual Machine Management and also loaded the Insight Control for VMware vCenter and Storage modules, i'm wondering what more i'll get from this?????

Any one got any comments on this??
AaronK
Frequent Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Here's another one hoping to see this. Has anyone called support to ask/report this as a 'bug'?
AaronK
Frequent Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

So when I import the NMI package into VUM, it is only applicable for esx? is anyone else having that problem?
Brian Proteau
Frequent Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

I'm actually going from ESX 4.0 to ESXi 4.1 nd I'm a bit confused.

I happen to be installing on a DL380 G5. Under the support files I see 2 downloads for ESXi 4.1

(a) HP ESXi Offline Bundle for VMware ESXi 4.1
(b) HP NMI Sourcing Driver.

(1) What are each of these?
(2) Are both required for Systems Insight Manager integration/functionality.

Also, this note on the NMI driver concerns me. It reminds me of ASR which I disable on ESX Hosts. The times I;ve seen that initiated have appeared to be unwarranted and I don't need random reboots of 50 VMs for a false positive event.

"If ESX/ESXi 4.1 does not have the HP NMI driver installed and in the event of a hardware fault, HP ProLiant systems may not shutdown due to the NMI event. The NMI event will be logged in the kernel logs and the system will continue execution."



DerekS_1
Frequent Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

Yes, HP really needs to package the CIM bundle into a VUM update. In fact that's the whole reason I came to this forum was to post and ask HP if they can do that.
AaronK
Frequent Advisor

Re: Upgrading ESXi 4.0 to 4.1 on HP DL380 G6 - 4.1 CIM Providers?

We are chatting about this exact issue on this post...
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1440349