Operating System - VMware
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual connect and ESX

Taj jundi
Occasional Contributor

Virtual connect and ESX

Hello,

So i have c7000 enclosure, 3 blades BL460c and 2 Flex10 interconnect.

Only one interconnect has two cables connected to it since the the client is waiting for their second switch however the problem i'm facing is as following:

First i configured Virtual connect
-two shared uplinks, one for each interconnect and only two cables physically connected to the first IC.
- 3 ethernet networks on the first interconnect (where the cables are connected), one for management, one for VMs and one for Vmotion
- 2 ethernet networks on the second interconnect, Management and VMs

and Ofc each server has a profile of 5 networks
(please note that management is 500mb speed, VMs are 3GB and Vmotion is 2 GB)

i have installed ESX on the servers, after the installation is complete i'm not able to ping the server, so i go to the service console and i change the vSwitch0 uplink from uplink0 to uplink2 in order to be able to connect to it.

the problem seem that the server is only accessable through network via UPLINK2, and i have tried the following, nothing worked

1st- changed the switch uplink to the rest of the uplinks one by one and non of them worked

2- created new vswitch with service console, and i assign uplink0 to it with and a new IP, i get to ping it but as soon as i delete the old switch (even after making the new switch the current gateway) i can't ping it, it's as if the rest of the uplinks can be contacted only through uplink two ....


Would appreciate your help
Attached is the support ticket

5 REPLIES
Jan Soska
Honored Contributor

Re: Virtual connect and ESX

Hello,
HP plans very similar config in our company in one month, then we can share our experience.

Jan
dchmax
Frequent Advisor

Re: Virtual connect and ESX

Which BL460 generation are you using? What verion of ESX? What firmware Rev are the Flex10 Modules at? We are running BL490 G6 which have the Flex 10 onboard nics. 2.30 and higher has DCC (DataLink Control Channel)implemented, and that directly affects the network card firmware and OS driver.

Here is our setup, hopefully it helps. Flex10's in IC 1 and 2, each have 4 cables attached to Switch 1 and 2 respectively. Those 4 cables create a network trunk, Uplink A and B, Active/Active. From there I've create vNets for each side, so VLAN_1a for side A and vland_1b for side B. So I did this for all the vlans that needed to be passed through. The ESX host profile has 8 network cards, 4 for each flex10. 1a and 2a console, 2a and 2b vmotion, 3a and 3b vm traffic. My experience has been that ESX 3.5 U3 and up and 4.0 support flex10, but will not work with SmartLink (DCC). We downgraded the firmware code, using firmware maint cd 8.60, of the NIC so it would not recognize DCC (4.8.0). When creating vswitches and added the network card, I turned on beacon probing. I believe ESX 4.1 the driver is included but I've heard there are issues.

I hope this helps and not to confusing.
Taj jundi
Occasional Contributor

Re: Virtual connect and ESX

Jan Suska, yeah sure and let me know how it goes. and during my research i would really recommend you to read a cookbook for virtual connect and esx from HP, it was really helpful and it has everything you need, i lost the link but downloaded the document :)

dchmax, i have bl460c G6 and ESX 4.1, as for the firmware downgrade i've done that already.

but by now i think the problem is solved but i ran out of time and the client working hours were over. however after changing the network order in a profile for one of the servers it worked, what i assume is that it has to be something with vSwitch0 Vlan ID along with the vlan id i assigned to the ethernet network, but what i didn't understand and will hopefully figure it out tomorrow is why only one uplink worked even after trying to delete the switch completly and creating it in the CLI with the proper Vlan ID, anyway will keep you posted and thanks for the reply
Steven Clementi
Honored Contributor

Re: Virtual connect and ESX

hi:

If you are still having problems...

I am quite familiar with your set up (hardware wise.. and from the vmware persepctive). Can you attach screen shots of your server profiles, network profiles, etc from the virtual connect manager?

Also, are you sure your network ports are configured properly? Sounds like maybe 1 of them is not passing traffic properly.


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)
Taj jundi
Occasional Contributor

Re: Virtual connect and ESX

Well, problem was solved, it was mainly because of their network configurations, the network administrator didn't know that the Vlan he gave us was the native vlan :)

and after that, the switch configurations i asked him to make was not configuraed properly.

eventually my configurations was:

interface GigabitEthernet0/1
description Connected With HP
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/2
description Connected With HP
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/3
description Connected With HP
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/4
description Connected With HP
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active

both interconnect connected to the same switch, this is why two channel groups was created.

However, i noticed that in Vcentre, in configurations under network adapters, only network card on vlan 2 are observing ip addresses and the other two which are on different Vlan are not observing IP addresses.
i read on some forums that it's fine but not sure though