Operations Orchestration Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

RAS Command Path entry

Occasional Advisor

RAS Command Path entry

I am trying to fix a flow I had working a few months ago.  I am using the RAS Command operation to kick off a PERL script.  


The inputs requested for the operation are:

command - the command to execute.
arguments - any arguments to command.
environment - Specifies environment variables/values that need to be defined when running command.
path - The path to the commands executable


I have the following entered:

command - c:\PerlScripts\Script1
arguments -
environment - 
path - c:\temp


When I run the flow I get {returnCode=1;returnResult=directory c:\temp does not exist;sessionId=iconclude-511828700915354521;exception=directory c:\temp does not exist;}


This flow was working previously.  I have verified the script exists in c:\PerlScripts on the RAS server.  I have tried other entries for the path variable and all other attempts have failed.


Does anyone have any thoughts as to why this is failing?


Thanks in advance.


Trusted Contributor

Re: RAS Command Path entry

Is there any reason you need to supply a path? The command input will run your script since you have fully qualified the path.


If you do need the Path input it needs to be a directory which actually exists; I just tested on OO9 CP10 with Path as blank, Path as directory which exists and Path as directory which does not exist. Only the last test case failed.


Lastly is the command running on the correct RAS set by the overrideJRAS variable? You can verify that in the step inspector. If it is running on a different RAS to what you expect that could be why you are getting Path failures since the directory does not exist on the wrong RAS.


Hope this helps somewhat.

Occasional Advisor

Re: RAS Command Path entry

If I don't add a path I get the following error "{returnCode=1;returnResult=The system cannot find the path specified.
;STDERR=The system cannot find the path specified.

I cannot see any information about the jras in the step inspector.
Trusted Contributor

Re: RAS Command Path entry

Does the path you have entered into the command input still exist?


Are you trying to run the command on the ras Ras_Operator_Path which is the default RAS built into OO? If you are trying to run it on a different RAS and don't see the overrideJRAS variable set in the step inspector then the operation is trying to run on Ras_Operator_Path.

Occasional Advisor

Re: RAS Command Path entry

[ Edited ]

I am trying to run it on the default ras (should be the same box as the repository in the environment I am working in). The RSJRAS service is started on the box as well.


All path information I am entering is existing on the RAS box as well.

Trusted Contributor

Re: RAS Command Path entry

Is the command input inheriting its value from a variable or a constant? If it's from a variable has it been overwritten with something unexpected?


What if you try to just run an 'ipconfig' command? Does that return what you expect?


Alternatively you could also try the Remote Command Execution object.


What version and CP of OO are you using?

Trusted Contributor

Re: RAS Command Path entry

[ Edited ]



Are you trying to run a perl script at your windows RAS?  Have you tried to enter only these two parameters?


overrideJRAS - RAS_Operator_Path (Actually enter the RAS name of your system)

command - perl c:\PerlScripts\Script1.pl


If you are trying to run a script with arguments try to run like this.

perl c:\PerlScripts\Script1.pl "${argument1}" "${argument2}" "${argument3}"


P.S: Be sure that perl is installed at your windows RAS and check your perl.exe path.


Best Regards