PCM
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

 
Handshaw
Advisor

Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

When we upgraded our HP Switch E5406zl(J8697A) from K.15.05.0002 to K.15.07.0008 it DID "Hang" (as warned by the download page), Power off/on did bring the switch back online, however our simple 6 character (all lower case) password was lost so I had to hit the clear button after trying everything to get access...2 Big Glitches in one little upgrade.

I notice that in any web-browser (WEx, FF, Chrome) the Home>Status>Device View is bugged showing

"style = "font-size:9px;color:#777;"
in empty slots C and D instead of reading "(Empty)" as version K.15.05.002 neatly shows.
Also on that page, using Windows Explorer the Transmit statistics are displayed at the bottom of the Details box instead of alongside of the Receive statistics (IN EITHER VERSION) 
Note: these display correctly in Chrome
Note: these do NOT display correctly in Firefox, but they are closer to where they should be.
6 REPLIES 6
Watchtower Society
Occasional Visitor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

We had EXACTLY the same problem after updating from 15.06.008 to 15.07.0008 on the same switch model E5406zl.

 

Just interested in knowing if you found out any further information such as why or how to prevent/fix?

 

Apart from Web Interface display problem you mention, and having to re-set the password to be able to get back into the switch interface, all seems to be working.

 

Many Thanks,

Michael

Handshaw
Advisor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

My next 2 switch upgrades on a couple of E5412z from firmware K.14.65 (we had had a MAJOR problem with K.14.84 causing network slowdowns with logins taking forever, application screens not painting) went a little better in that they didn't lock up and need to be power cycled...I only needed to hit the clear button and reset the passwords...

I'D STILL LIKE TO KNOW WHAT THEY ARE REVERTING TO SO I COULD RESET THEM REMOTELY INSTEAD OF BEING REQUIRED TO HAVE ACCESS AND PHYSICALLY CLEAR THE PASSWORDS ON THE SWITCH...WE NEVER HAD UPGRADE PROBLEMS LIKE THIS WITH OUR OLD ENTERASYS EQUIPMENT.

Handshaw
Advisor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

I just discovered that my E5412zl swiches that were downgraded from K.14.84 back to K.14.65 after the problems we had with version K.14.84 (after the downgrade the problems all went away), all are in a strange password limbo.

After the upgrade I could no longer Web-view into these devices but could still Telnet (which both use the same passwords, so I figured the webview was being blocked by some weird condition caused by the downgrade, but I decided to clear the passwords on one of them Friday and today I coudl get in and update the passwords?!?

Strange that I could Telnet in (sonething I couldn't do with the above upgrades), but not web-view in considering both use the same username(none) passwords.

 

I really hate losing the graphics representation of the switch that version K.14 and before offered...that K.15 popcycle stick representation (filled with display error messages) really is hard to live with.

Handshaw
Advisor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

Get this...

after the downgrade from K.14.84 back to K.14.65 I couldn't get into webview until I cleared the passwords...

turns out after I set the passwords again I couldn't get in again?!#@!

Get this...

However if I sat there hitting login over and over again I managed to get in sooner or later?!#@!

There's something really messed up here.

Watchtower Society
Occasional Visitor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

Turns out the problem was caused by using blank manager and operator usernames and just having a password.

 

After adding the usernames we were able to perform firmware upgrade and the switch restarted automatically without loss of password.

 

This was after one upgrade corrupted the boot ROM and the switch would not restart or connect at all. Needed a new management module sent out by HP to fix.

 

After spending a lot of time talking with HP it turned out the blank manager and operator usernames prevented the update from completing and the switch restarting properly.

Bidexhouse
Occasional Visitor

Re: Problems with K.15.07.0008 firmware on our HP Switch E5406zl(J8697A)

Hi guys:

 

i had the same issue and i solved by getting physical access to the
switch and pressing and holding the Clear button for a full second.

 

then i created a management user and voila, i am happy now :-)

 

I hope it helps everyone