Patches
Showing results for 
Search instead for 
Do you mean 

HP-UX 11.11 bash binary for PA-RISC1.1

Highlighted
Advisor

HP-UX 11.11 bash binary for PA-RISC1.1

[ Edited ]

Hi,

I have HP-UX 11.11, downloaded and installed bash shell from this URL http://hpux.connect.org.uk/hppd/hpux/Shells/bash-3.2/

When I run bash its giving incompatible binary message.

Where can I download PA-RISC1.1 compatible bash binary depot?

file /bin/ls
/bin/ls: PA-RISC1.1 shared executable dynamically linked


Thanks

 

 

 

P.S. This thread has been moved from HP-UX > General > to HP-UX > patches. -HP Forum Moderator

7 REPLIES
Exalted Contributor [Founder]

Re: HP-UX 11.11 bash binary for PA-RISC1.1

Shalom,

If its PA-RISC 1.1 then it will work on HP-UX 11 if its 1.1 or 2.0 it will work on your OS.

What you download from the link above is a depot file.

Lets sya its bash-3.2.depot.gz
We faved it in /tmp

gunzip bash-3.2.depot.gz
swiinstall -s /tmp/bash-3.2.depot \*

Now the binaries are installed.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Acclaimed Contributor [Founder]

Re: HP-UX 11.11 bash binary for PA-RISC1.1

Do you have PA 1.1 or PA 2.0 hardware?
What does model(1) say?
Advisor

Re: HP-UX 11.11 bash binary for PA-RISC1.1

Today I installed sudo on the same box. its says Execute permission denied.

$/usr/local/bin/sudo
sh: /usr/local/bin/sudo: Execute permission denied.


$ ls -l /usr/local/bin/sudo
---s--x--x 2 root root 135168 Nov 6 12:10 /usr/local/bin/sudo

$ file /usr/local/bin/sudo
/usr/local/bin/sudo: PA-RISC2.0 shared executable dynamically linked

$ model
9000/851/D260

Thanks




Honored Contributor [Founder]

Re: HP-UX 11.11 bash binary for PA-RISC1.1

Checking the /bin/ls binary won't tell you much. Most binaries in the OS are compiled for PA-RISC 1.1. Since you're on a D260, however, you just happen to be on a pre-PA-RISC 2.0 system.

Very few, if any, depots from the Porting and Archive site are for PA-RISC 1.1. You will need to download the source and compile what you want to use.
--
Jeff Traigle
Acclaimed Contributor [Founder]

Re: HP-UX 11.11 bash binary for PA-RISC1.1

>9000/851/D260

This is a PA7200, so you were correct in asking for a PA-RISC1.1. As Jeff said, you'll need to get your own.
Occasional Visitor

Re: HP-UX 11.11 bash binary for PA-RISC1.1

usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libtermcap.sl Error

Hello friends
I want to install bash in HPUX, i have download bash4.2.045 deport from hpux site and all its dependencies like below
gettext 0.18.2.1 gettext
libgcc 4.2.3 libgcc
libiconv 1.14 libiconv
make 3.82 make
ncurses 5.9 ncurses
termcap 1.3.1 termcap

i have installed them with
swinstall -s /tmp/<deportName> command

but still i am this this error

/usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libtermcap.sl.

in HPUX forum people are saying that only libconv, termcap and gettext will solve the problem, but still i am getting this error message. and yes libtermcap.sl file is not there even after installing termcap depot. pls help.

 

I am new to hpux, pls help me a warm thanks for you.

Acclaimed Contributor [Founder]

Re: HP-UX 11.11 bash binary (libtermcap.sl missing)

>people are saying that only libconv, termcap and gettext will solve the problem but still I am getting this error message. and yes libtermcap.sl file is not there even after installing termcap depot.

 

Which depot did you install for termcap?

In termcap-1.3.1-hppa-11.31.depot, I see /usr/local/lib/libtermcap.sl.

 

What does "swlist -l file termcap-RUN" show?