BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
Patches
Showing results for 
Search instead for 
Do you mean 

Problem installing a .depot file on 11.31

SOLVED
Go to Solution
Highlighted
Occasional Collector

Problem installing a .depot file on 11.31

I downloaded a .depot file from HP, it's ANSI C++ but doesn't appear to be a depot file, I think it's a .tar file.  How do I handle this as I expected I would have to use my supplied codeword during the install.  In trying to just get a listing of what the file contains, swlist fails and tar creates a listing (see below).

 

# swlist -l product -s HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.3>

# Initializing...

# Contacting target "HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.31.06_

HP-UX_B.11.31_IA_PA.depot"...

ERROR: Could not contact host

"HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.31.06_HP-UX_B.11.

31_IA_PA.depot".

Make sure the hostname is correct and an absolute pathname is

specified (beginning with "/").

ERROR: More information may be found in the daemon logfile on this

target (default location is

HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.31.06_HP-UX_B.11.3

1_IA_PA.depot:/var/adm/sw/swagentd.log).

 

#

 

# tar -tvf HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.31.06_HP-UX_B>

rw-r--r-- 0/3 81373 Jun 27 17:11 2011 catalog/INDEX

rw-r--r-- 0/3 267 Jun 27 17:11 2011 catalog/dfiles/INDEX

rw-r--r-- 0/3 138 Jun 27 17:11 2011 catalog/dfiles/INFO

r--r--r-- 0/3 2588 May 23 14:53 2011 catalog/ACXX/pfiles/INDEX

r--r--r-- 0/3 163 May 23 14:53 2011 catalog/ACXX/pfiles/INFO

r--r--r-- 0/3 376 May 23 14:53 2011 catalog/ACXX/ACXX/INDEX

r--r--r-- 0/3 3411 May 23 14:53 2011 catalog/ACXX/ACXX/INFO

r-xr--r-- 0/3 1756 Jan 11 19:12 2011 catalog/ACXX/ACXX/configure

r-xr--r-- 0/3 986 Jan 11 19:12 2011 catalog/ACXX/ACXX/postremove

r-xr--r-- 0/3 3986 Jan 11 19:12 2011 catalog/ACXX/ACXX/preinstall

r-xr--r-- 0/3 1130 Jan 11 19:12 2011 catalog/ACXX/ACXX/unconfigure

r--r--r-- 0/3 385 May 23 14:54 2011 catalog/ACXX/ACXX-HELP/INDEX

r--r--r-- 0/3 309317 May 23 14:54 2011 catalog/ACXX/ACXX-HELP/INFO

r-xr--r-- 0/3 1539 Jan 11 19:12 2011 catalog/ACXX/ACXX-HELP/configure

r-xr--r-- 0/3 1564 Jan 11 19:12 2011 catalog/ACXX/ACXX-HELP/preinstall

r--r--r-- 0/3 415 May 23 14:56 2011 catalog/ACXX/ACXX-JPN-E-MAN/INDEX

.

.

.

.etc

3 REPLIES
Acclaimed Contributor

Re: Problem installing a .depot file on 11.31

>but doesn't appear to be a depot file, I think it's a .tar file.

 

Tape depot files are usually tar files but can also be cpio.

 

>How do I handle this as I expected I would have to use my supplied codeword during the install.

 

You do what the error message says.

 

># swlist -l product -s HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.3>

>Make sure the hostname is correct and an absolute pathname is specified (beginning with "/").

 

You need to do use an absolute path:

swlist -l product -s $PWD/HP_a_C++_ANSI_C_Developers_Bundle_E-LTU_B9007AA_C.11.31.06_HP-UX_B.11.31_IA_PA.depot

Occasional Collector

Re: Problem installing a .depot file on 11.31

I probably won't explain this correctly but basically the depot file was referring to directory.  So the file was untar'd to a directory and that directory was used for the swinstall.  Never had to deal with something like that before.

Acclaimed Contributor

Re: Problem installing a .depot file on 11.31

>the depot file was referring to directory.  So the file was untar'd to a directory and that directory was used for the swinstall.

 

There is no need to do that.  You don't need to untar it at all.

If you do need to create a directory depot for remote installation, the correct command is swcopy, not tar.