Showing results for 
Search instead for 
Did you mean: 

problem trying to patch aCC

Philip Wood
Occasional Visitor

problem trying to patch aCC

I am trying to install some patches for aCC in order to compile something that requires libCsup_v2.2 and libstd_v2.2 - these are not currently installed on my system. I'm having a few problems that I've not managed to find any existing help on, so I hope someone on here might be able to help me...

I've checked the SCCS identification information of aCC:

21% what /opt/aCC/bin/aCC
HP aC++ B3910B A.03.30
HP aC++ B3910B A.03.27 Language Support Library

When I check in SAM Software Management->List Software->List Installed Software, the only c++ related entry I get is:

Bundle: B3913DB
Revision: C.03.30
HP aC++ Compiler (S800)
Size: 105517 Kbytes
Vendor: HP

So, I guess that I'm running with compiler version 3.30, and Language support library 3.27, and I guess this is all part of bundle C.03.30. OK. Now, I've found the aCC release history, which gives a list of patches for this version of the compiler, at,1703,1743,00.html#11

This is where I start getting confused... compiler 3.30 is a base release. Now, I assumed that the patches listed between compiler releases 3.31 and 3.30 are the patches that you need to apply in order to end up with the equivalent of release 3.31, is this correct? If so, what are the patches listed *below* release 3.30 and how come PHSS_22543, which is described as "s700_800 11.x HP aC++ -AA runtime libraries (aCC A.03.30)" is listed there?

Whatever, this patch contains libc v2.2 support. This patch also says "Every development site (on A.03.25 through A.03.27) must also install PHSS_22868". Is this talking about the Language Support Libarary version? I'm sure I found a post on here recently where someone else downloaded PHSS_22543 and PHSS_22868 to install libc v2.2, so I went ahead and tried to install them. Now, PHSS_22543 installed fine through SAM, but when I then tried to install PHSS_22868 it failed. The logfile says:

======= 02/20/03 15:06:58 GMT BEGIN install AGENT SESSION (pid=22328)

* Agent session started for user "root@srig2". (pid=22328)

* Beginning Analysis Phase.
* Source: srig2:/mobwork/tmp/patches/PHSS_22868.depot
* Target: srig2:/
* Target logfile: srig2:/var/adm/sw/swagent.log
* Reading source for product information.
* Reading source for file information.
NOTE: The fileset "PHSS_22868.ACXX-STDLIB,r=1.0" is a "sparse" or
"patch" fileset which may only be installed upon a previously
installed base fileset. The specification for the required
base fileset is "ACXX.ACXX-STDLIB,fr=C.03.27,v=HP". Since
there is no fileset on the target or selected from the source
which matches this specification, fileset
"PHSS_22868.ACXX-STDLIB,r=1.0" will be excluded.
* Executing preDSA command.

* Summary of Analysis Phase:
* 1 of 1 filesets will be Skipped.
* The Analysis Phase succeeded.

So, it's saying that I need the base release STDLIB 3.27. Is this the language support library? or is this the compiler? or is it something else entirely?

So, to summarise: I've got copmiler 3.30 and lsl 3.27, and I want to get hold of libCsup_v2.2 and libstd_v2.2. How do I do this? Forgive me if any of this sounds dumb but I'm not really an expert on this! Many thanks in advance.


eran maor
Honored Contributor

Re: problem trying to patch aCC

Hi Pilip

i have to say that i m not very good with telling you info about lib. but i wanted to comment one thing .

if you have install ACC 3.30 and you want to upgrade to version ACC 3.37 you will not need to update the patch but you will need to install the new version of the ACC and then the patch for it .

wehat i m trying to say that if you need to upgrade the version of the ACC you need to apply a new install of the product and not a aplay of a patch
love computers
Philip Wood
Occasional Visitor

Re: problem trying to patch aCC


I realise that if I wanted to install release 3.33 or higher I'd have to install a full version of the compiler, as this is the base release. But if I'm installing a base release, why then do I need to install any patches at all?

In any case, I don't think it is necessary for me to install a new base release - as far as I understand, the libc support is in patch PHSS_22543 which is for release 3.30. I just can't get the associated patch 22868 to install.


Dave Unverhau_1
Honored Contributor

Re: problem trying to patch aCC


I think that swinstall is simply telling you that you don't need PHSS_22868. As I interpret the patch text for PHSS_22868, it is only required for Ansi C++ compilers version 3.25-3.27, and the message from swinstall is telling you that the filesets corresponding to this version range are not on your system, so the patch doesn't apply.

After installing PHSS_22543 (btw, I would opt for PHSS_22945, as this patch contains a number of defect fixes that might be beneficial), you should have the libstd_v2.2 and libCsup_v2.2 filesets in /usr/lib, so you may have done all you need by installing PHSS_22543.



Romans 8:28