Showing results for 
Search instead for 
Did you mean: 

swa get is trying to download over FTP NOT HTTP

Go to solution
Occasional Contributor

swa get is trying to download over FTP NOT HTTP



Can someone confirm for me how I can force swa get to download patches via http and not use ftp? When i execute the following command the command completes successfully but no patches are actually downloaded to the depot and the proxy logs show that the server is executing FTP requests not http and external FTP access is blocked in this environment.


swa get -t /var/spool/swa_depot/ -x hp_id=useridname-x hp_pw=pword -x proxy=http://proxyserver:8080 \

-x http_proxy=http://proxserver:8080


I am sure that this tool is designed to use http so I don't see what I am missing.


Thanks in advance.



Re: swa get is trying to download over FTP NOT HTTP

Hi Sean


First of all what revision of SWA are you running.  The latest available on the web is C.02.85.


Can you download a catalog or are you using an old cached copy?  You can check the <catalogDate> near the top of the xml file.  e.g. /.swa/cache/swa_catalog.xml


Also, you don't need to specify http_proxy along with proxy.  Setting proxy is the default for all proxies.


Check your /etc/opt/swa/swa.conf file (or user conf file) for use of the download_cmd option which is used to override the swa default download commands, in effect changing the protocols as well.



Occasional Contributor

Re: swa get is trying to download over FTP NOT HTTP

Hi Lorenzo,


Thanks very much for chiming in. I have not used this tool in such a locked down environment before. I was using the C 02.85 version and I was aware that the "proxy" option setup the default but I was getting desperate. I had a current swa_catalog.xml being downloaded which was what confused me. Turns out someone messed around with the swa.conf file which I normally leave blank. The download_cmd section was still commented out but must have been something else in there.


Once I commented the swa.conf file out my command worked perfectly.


Thanks again,