Showing results for 
Search instead for 
Did you mean: 


Go to solution
Regular Advisor




I need to install patches on a production box recommended by HP and I was ask to verify other for other patches on the system.  I was running an old version of swa on that box and can not make it work.  I saw that the most recent version is 2.95, but since this is a production box, I decided to installed it on a demo server of HP.


The demo server was installed 2 weeks ago and already have version 2.95.  When I run the swa, I do get an error saying failed to access authorization service.  I saw as well, the need of installing a new certificate, what I did, but I'm still not able to connect.


Here is the output of the certificate and the output of swa verbosity=D


any help will be appreciated.




# /opt/java6/jre/bin/keytool -list \-keys
> -keystore /opt/java6/jre/lib/security/cacerts -storepass changeit |\
> grep -i -e "3C:48:42:0D:FF:58:1A:38:86:BC:FD:41:D4:8A:41:DE"
Certificate fingerprint (MD5): 3C:48:42:0D:FF:58:1A:38:86:BC:FD:41:D4:8A:41:DE

swa verbosity=D

# swa report -x verbosity=D
DEBUG: @(#)swm/drd: Revision: A. BuildOptions: optimized +O2 +Onolimit SRC: :revision:
branches/SWA_dev/smd@85299 BE: /build/BE/nightly/IA_11.23 Last Modified: 2012-11-12 16:03:42
@(#) (c) Copyright 2002-2012 Hewlett-Packard Development Company, L.P.
DEBUG: Entering: SWAUserTask::stateMachine

======= 01/20/14 16:56:17 EST BEGIN Report on Issues and New Software (user=root) (jobid=aurora)

DEBUG: Entering: SWAUserTask::doUpfrontChecksAction
DEBUG: Entering: SWAUserTask::doInventoryAction
* Gathering Inventory
DEBUG: Entering: SWAUserTask::getSourceArgument
DEBUG: Entering: SWAUserTask::getInventorySources
DEBUG: Exiting: SWAUserTask::getInventorySources
DEBUG: Exiting: SWAUserTask::getSourceArgument
* Checking existence and age of inventory for host "aurora"
DEBUG: Entering: SWAUserTask::calculateInventoryFilePath(const string&, string&)
DEBUG: Running command:
- /usr/bin/cksum
- /usr/bin/cksum
- /root/.swa/cache/.tmpHostname
DEBUG: 0x4004521c Potential inventory filename=/root/.swa/cache/swa_inventory_2776658324.xml
DEBUG: 0x7fffd69c Hostname found in file=aurora
DEBUG: Exiting: SWAUserTask::calculateInventoryFilePath(const string&, string&)
DEBUG: Entering: SWAUserTask::inventoryFileOutOfDate
DEBUG: 1390254978 seconds since the EPOCH is the CURRENT TIME
DEBUG: 1390245146 seconds since EPOCH for inventory source "aurora"
DEBUG: ----------
9832 seconds difference in the above times.
86400 is the max age in seconds
* Inventory for host "aurora" is newer than 24 hours
* Using existing inventory for host "aurora"
DEBUG: Exiting: SWAUserTask::inventoryFileOutOfDate
DEBUG: Entering: SWAUserTask::doRunJavaSteps
Enter your HP user ID: cscott
DEBUG: Running command:
- /usr/bin/stty
- /usr/bin/stty
- -echo
Enter your HP Password:
DEBUG: Running command:
- /usr/bin/stty
- /usr/bin/stty
- echo
DEBUG: Entering: SWAUserTask::getIgnoreFiles
DEBUG: Entering: SSWAProxy::startJVM
DEBUG: Entering: SSWAProxy::createJVMOptions
DEBUG: Exiting: SSWAProxy::createJVMOptions
DEBUG: Started JVM.
DEBUG: Entering: SSWAProxy::newMessageLoggerObject
DEBUG: Exiting: SSWAProxy::newMessageLoggerObject
DEBUG: Entering: SSWAProxy::callStartLoggingJavaOutputMethod
DEBUG: Exiting: SSWAProxy::callStartLoggingJavaOutputMethod
DEBUG: Exiting: SSWAProxy::startJVM
DEBUG: Entering: SSWAProxy::getCatalogURLOverrideString
DEBUG: Entering: SSWAProxy::newFFSOverrideObject
DEBUG: Exiting: SSWAProxy::newFFSOverrideObject
DEBUG: Entering: SSWAProxy::callGetCatalogURLStringMethod
DEBUG: >>Entering method FFSOverride.readURLConfFile()
DEBUG: <<Exiting method FFSOverride.readURLConfFile()
DEBUG: Exiting: SSWAProxy::callGetCatalogURLStringMethod
DEBUG: Exiting: SSWAProxy::getCatalogURLOverrideString
DEBUG: Entering: SSWAProxy::getToken
DEBUG: Entering: SSWAProxy::newTokenGetterObject
DEBUG: Entering: SSWAProxy::getProxyForTokenGetter
DEBUG: Entering: SSWAProxy::callGetTokenAcquisitionURLProtocolMethod
DEBUG: Exiting: SSWAProxy::callGetTokenAcquisitionURLProtocolMethod
DEBUG: Exiting: SSWAProxy::getProxyForTokenGetter
DEBUG: Entering: SSWAProxy::getDownloadCommandForTokenGetter
DEBUG: Exiting: SSWAProxy::getDownloadCommandForTokenGetter
DEBUG: Entering: SSWAProxy::getUrlTargetString
DEBUG: Exiting: SSWAProxy::getUrlTargetString
DEBUG: >>Entering method TokenGetter.TokenGetter(, %url, )
DEBUG: fDownloadCommand: "null"
DEBUG: fUrlTarget: "%url"
DEBUG: <<Exiting method TokenGetter.TokenGetter(, %url, )
DEBUG: Exiting: SSWAProxy::newTokenGetterObject
DEBUG: Entering: SSWAProxy::callGetToken
DEBUG: >>Entering method TokenGetter.getToken()
DEBUG: >>Entering method TokenGetter.requestNewTokenWithRetry("cscott", "pHpPw")
DEBUG: >>Entering method TokenGetter.askAuthServerForToken()
DEBUG: >>Entering method TokenGetter.makeUrlRequest()
DEBUG: Using token url:
DEBUG: URL request failed:
DEBUG: <<Exiting method TokenGetter.makeUrlRequest()
ERROR: Failed to access authorization service.
- SMDExcep was thrown from the following location:
file: jni/
method: SSWAProxy::callGetToken
line: 610.
DEBUG: Entering: SSWAProxy::stopJVM
DEBUG: Stopping JVM.
DEBUG: Entering: SSWAProxy::callStopLoggingJavaOutputMethod
DEBUG: Exiting: SSWAProxy::callStopLoggingJavaOutputMethod
DEBUG: Exiting: SSWAProxy::stopJVM

======= 01/20/14 16:56:37 EST END Report on Issues and New Software failed with 1 error. (user=root)

NOTE: More information may be found in the Software Assistant logfile "/var/opt/swa/swa.log".
DEBUG: Exiting: SWAUserTask::stateMachine
DEBUG: Entering: SWAUserTask::~SWAUserTask
DEBUG: Exiting: SWAUserTask::~SWAUserTask
DEBUG: Entering: UserTask::~UserTask
DEBUG: Exiting: UserTask::~UserTask



P.S. This thread has been moevd from HP-UX > System Administration to HP-UX > patches. - Hp Forum moderator


Frequent Advisor

Re: swa

Are you connecting through a proxy server and do you have the 'https_proxy' parameter set correctly in your config file? You might also test it with 'crl_check=false'.

Regular Advisor

Re: swa



no, I have a direct access to the internet.



Regular Advisor

Re: swa



sorry, after reviewing the config, I realised that my nsswitch.conf files under hosts only had files and not dns.


thank you for your help.