Patches
cancel
Showing results for 
Search instead for 
Did you mean: 

swinstall is taking wrong machine name instead local machine

SOLVED
Go to solution
Highlighted
madhavabk
Regular Advisor

swinstall is taking wrong machine name instead local machine

Hi,
I am running swinstall command on a host01.
But swinstall command will use host02 to find packages and hangs then after some time will inform unavailability of depots.

So how to chage the default host name.

Thanks,
Madhava
6 REPLIES
Zeev Schultz
Honored Contributor
Solution

Re: swinstall is taking wrong machine name instead local machine

why it uses host02? checked /etc/hosts, /etc/nsswitch.conf - IP duplicates, wrong host info etc?

basically when you run 'hostname' command it returns what?
So computers don't think yet. At least not chess computers. - Seymour Cray
Devender Khatana
Honored Contributor

Re: swinstall is taking wrong machine name instead local machine

Hi,

It is also possible that the registered depot is located on an unavailable NFS mount point from host02 to which your host01 tries to locate.

Use "swinstall -s /path_to_depot" Or follow swinstall by a "swreg -l depot /Path_to_depot"


HTH,
Devender
Impossible itself mentions "I m possible"
Bharat Katkar
Honored Contributor

Re: swinstall is taking wrong machine name instead local machine

Hi Madhava,

See what "hostname" command shows and whether that is the hostname you are expecting.
Also check /etc/hosts and /etc/nsswitch.conf files.
In case you require to change hostname use "set_parms hostname".
Try pinging hostname it should show your server name and it's ip.

Regards,
You need to know a lot to actually know how little you know
Steven E. Protter
Exalted Contributor

Re: swinstall is taking wrong machine name instead local machine

Its got to be an error in:

DNS name resolutions (check /etc/resolv.conf)
/etc/hosts resolution

see /etc/nsswitch.conf to see how name resolution is set up.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Muthukumar_5
Honored Contributor

Re: swinstall is taking wrong machine name instead local machine

To get depot from localhost use simply as,

# swinstall -s

hth.
Easy to suggest when don't know about the problem!
madhavabk
Regular Advisor

Re: swinstall is taking wrong machine name instead local machine

Hi all,

Nice getting information.

The problem ofcourse was with respect to /etc/hosts file only.

I have changed the contents of the file and it required the reboot to get settings changed.


Thanks,
madhav