Performance Center Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

vugen error - opening script in ALM


vugen error - opening script in ALM


Vugen is actively connected to ALM.  The ALM project has version control.  From vugen, I am trying to open up a script in the ALM project under Test Plan. 


I get the following error:

File not found



The script is there and it is not checked out.  Does anyone have any information?


Thank you.


HPE Expert

Re: vugen error - opening script in ALM



Can you please describe the complete steps you are doing? It is hard to analyze what went wrong when versioning is applied without full description.


For example: did you check out the script from ALM UI and then tried opening it in VuGen? or maybe you checked-out the script from VuGen and then tried opening it? Can it be that another user checked-out the script that time? etc....







Re: vugen error - opening script in ALM

Thank you for your time in replying.  I appreciate it. 

It is currently not checked out.  There are no locks on it.  I also did a copy and paste of the folder to a different project that does not have version control.  I got the same error. 


I then logged into ALM and did a download.  Then I uploaded it to the non version control project.  I logged off and then was able to open up the script from vugen. 


I am also able to open up other scripts in the same project and the non version control project with no problems. 


Thank you for any assistance you can provide. 


HPE Expert

Re: vugen error - opening script in ALM



It seems like this particular script got corrupted somehow. In order to understand the root cause of this issue there is a need to drill down into:

> Server log in order to look for possible related errors

> VuGen log file


If the logs are insufficient there is a need to look at few database tables related to the script model in ALM as well as the file repository.


Sounds like you manage to work around this issue. If this issue reproduces with other scripts I suggest you open a support ticket to investigate it.


Good luck




Re: vugen error - opening script in ALM

Resaving the script with a diffirent name and then saving it back to original name worked for me on such issue

Occasional Advisor

Re: vugen error - opening script in ALM


I had similar issue - During upload of VuGen scripts to the repository, on certain scripts, the Action script block woul dbe stripped . Essentially when checking the Action .c file on the repository or in ALM, it would be blank. I engaged HP Support , had many web ex session to investigate , provided all the logs requested by them. In the end, HP did not resolve the issue. They were not even able to arrive at a root cause let alone a fix. Ultimately , I created  a new Performance Center project and the scripts were uplaoded and tested. This appeared to fix the problem. For some unknown reason, either the scripts or the Perf. Ctr project had gotten corrupted.

Occasional Contributor

Re: vugen error - opening script in ALM

Hi , I am not having exactly the same issue but a similar one.

I connect ALM with Loadrunner and do save as and save my loadrunner scripts into Test Plan section of HP ALM.

Now the issue is the option for checking out this script is grayed out or disabled. While I am getting option for checking out the QTP script ( also uploaded at the same place).


Please advise about the probable workaround.


Thanks in advance.