Planning
Showing results for 
Search instead for 
Do you mean 

HP-UX 10.20 to 11.00 Update, Binary Compatibilities

SOLVED
Go to Solution
Occasional Advisor

HP-UX 10.20 to 11.00 Update, Binary Compatibilities

I need to update two production servers from 10.20 to 11.00. These servers hosts a number of applications, some of the high profile apps being:
sendmail 8.9.3
SAS 6.12
SPlus 5.0
SPSS

My main concern is sendmail. I am not sure if there will be a binary compatibility problem. What steps must I take that to ensoure sendmail will continue to work correctly after the servers have been updated to HP-UX 11.00.

Thanks,
Steve
2 REPLIES
Acclaimed Contributor

Re: HP-UX 10.20 to 11.00 Update, Binary Compatibilities

Hi Steven,

As far as sendmail goes, I never considered binary compatabilty. All you need to do is install the 11x version of sendmail (with patches) and then transfer you configuration files in /etc/mail (aliases, mailcap, sendmail.cf, sendmail.cw, and service.switch) from your 10.20 version to the 11x version.
Start sendmail and your done.

I am assuming you have name resolution up and running. I have found no differences between equivavlent versions of sendmail between 10.20 and 11x.

Hope this helps, Clay
If it ain't broke, I can fix that.
Honored Contributor

Re: HP-UX 10.20 to 11.00 Update, Binary Compatibilities


Indeed there have been cases of applications not working 100% after upgrading from HP-UX 10.20 to 11 - as previously discusson in this forum. I would suggest that you consult with your application providers (SAS, SPlus, SPSS) to see if the same versions of their application are supported on HP-UX 11 - then if you have problems you can call them for support, or if not they should recommend an upgrade to a supported version, which you should do.
Im from Palmerston North, New Zealand, but somehow ended up in London...
//Add this to "OnDomLoad" event