cancel
Showing results for 
Search instead for 
Did you mean: 

SPSS 6.1

Deborah Weatherspoon
Frequent Advisor

SPSS 6.1

I know this is a long shot, but does anyone still use SPSS 6.1 for UNIX ????.......

I applied some HPUX patches this weekend and all of a sudden SPSS does not work anymore. The error message says that SPSS cannot open its error message file. I changed the err.msg to 777, but it's still complaining.

I applied 141 patches, so I was hoping that someone could point me in the right direction
8 REPLIES
Jeff Schussele
Honored Contributor

Re: SPSS 6.1

Hi Deborah,

Did the ownership or perms change on the dir which contains the error message file?
Does the user that starts the SW have perms to write into the dir.
If the user has no read perms in the dir, then the user cannot access the files inside.

It's also possible that the file has become corrupted. Can you rename it & touch a new file in it's place - setting appropriate ownership/perms?

Rgds,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Mark Greene_1
Honored Contributor

Re: SPSS 6.1

Did you verify the directory permissions on the complete path to the file? You may have lost execute permissions somewhere along the way, and hence the ability to cd into the directory.

With 141 patches, I would think that the likelihood is high that you rebooted. In the event that you didn't, run fuser on the file and see if there is an exclusive update lock on it.

mark
the future will be a lot like now, only later
A. Clay Stephenson
Acclaimed Contributor

Re: SPSS 6.1

Your first task would be to attempt to cat the file as whatever user actually runs spss. I would also do a chatr or ldd and check that all the expected shared libraries still exist and can be accessed by this user. An echo ${?} immediately upon SPSS exit would also be helpful as an indication of the exit status/errno.

Plan B. Have you considered replacing SPSS with its Gnu counterpart, PSP? -- available from any of the HP-UX Porting Centre's.
If it ain't broke, I can fix that.
Deborah Weatherspoon
Frequent Advisor

Re: SPSS 6.1

Thanks Jeff, Mark and Clay,

No the permissions did not change and yet the system did reboot. The license file is running , but the program is not. I did touch the err.msg file but it did not matter.

Clay, could you please give me an example of using chatr or ldd. Sorry for my lack of knowledge about their uses.
Sridhar Bhaskarla
Honored Contributor

Re: SPSS 6.1

Hi Deborah,

I have absolutely no idea about SPSS. But I suggest you run it with tusc and see if you get any clues out of the tusc output. Tusc basically traces the system calls and provides a detailed output and it may give you some hints.

You can obtain tusc from HP's porting center.

http://hpux.cs.utah.edu/hppd/hpux/Sysadmin/tusc-7.5/

It is very useful if you load this tool on your system.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
A. Clay Stephenson
Acclaimed Contributor

Re: SPSS 6.1

Chatr w/o args can be used to list the shared libraries used by an executable. Here's a simple example, chatr'ing /usr/bin/cat.

$ chatr /usr/bin/cat
/usr/bin/cat:
shared executable
shared library dynamic path search:
SHLIB_PATH disabled second
embedded path disabled first Not Defined
shared library list:
dynamic /usr/lib/libc.2
shared library binding:
deferred
global hash table disabled
plabel caching disabled
global hash array size:1103
global hash array nbuckets:3
shared vtable support disabled
static branch prediction disabled
executable from stack: D (default)
kernel assisted branch prediction enabled
lazy swap allocation disabled
text segment locking disabled
data segment locking disabled
third quadrant private data space disabled
fourth quadrant private data space disabled
data page size: D (default)
instruction page size: D (default)
-------------------------------------------

The preferred command is ldd, list dynamic dependencies, here's its output


$ ldd /usr/bin/cat
/usr/lib/libc.2 => /usr/lib/libc.2
/usr/lib/libdld.2 => /usr/lib/libdld.2
/usr/lib/libc.2 => /usr/lib/libc.2

---------------------------------------

Depending upon your OS, you may or may not have ldd but you will always have chatr. Man chatr,ldd for details. Chatr can also be used to tell an executable where to look for libraries --- which may be needed in your case.


$
If it ain't broke, I can fix that.
Deborah Weatherspoon
Frequent Advisor

Re: SPSS 6.1

Thanks Sridhar and Clay,

I tried chatr /usr/lpp/SPSS/bin/err.msg and /usr/lpp/SPSS/bin/spss but I got an error msg that said that chatr cannot recognize file type of file. When I tried the ldd command my 11i system said that ldd not found....

I'm going to unpatch the system tonight so that the users can run tommorrow....


Thanks again for your help
Sridhar Bhaskarla
Honored Contributor

Re: SPSS 6.1

Hi,

There is no guarantee that the patching created this problem. The problem might be due to the reboot of the server. You will know more details if you run 'tusc'. Once it is installed, you can run

/opt/tusc/bin/tusc -f -o /tmp/spss.out "command_to_ start_your_spss_program"

And attach spss.out file here and someone can look at it and see if we can figure out anything from there.

Ofcourse, you can go ahead with uninstalling the patches. If the problem is still there, you can always try the above.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try